AxiDraw® V3

High Performance
Writing and Drawing Machines

User Guide

Models:
AxiDraw V3 (Model 2510), AxiDraw V3/A3 (Model 2520),
AxiDraw SE/A3 (Model 2530), AxiDraw V3 XLX (Model 2550)

Version 4.5
Last updated: January 24, 2021
Preliminaries

0.1 Welcome to AxiDraw!
This is the user guide for the AxiDraw V3 family of high-performance personal writing and drawing machines. This guide is here to help you get started. There is a lot here — covering how you set up and use the machine, tips for operation, details about the software, and pointers to additional resources.

This guide covers operation of the following AxiDraw models:
- AxiDraw V3
- AxiDraw V3 XLX
- AxiDraw V3/A3
- AxiDraw SE/A3

Additionally, sections 3-13 of this guide, covering everything except the physical setup of the machine, are applicable to the AxiDraw MiniKit.

0.2 This guide is updated from time to time.
Both this guide, and the AxiDraw software are updated from time to time. We encourage you to check back occasionally for the latest version of this manual, and to check that you have the latest version of the software. You can also use the Config tab of AxiDraw Control to check online to see if you have the latest version.

Recent changes to this guide include updates to the current software version, which is v2.7, new advanced features for plot optimization, plotting to multiple AxiDraw machines, and an all-new version of Hershey Text.

You can download the latest version of this guide at http://axidraw.com/guide

Look at the front cover of the guide to find the date and version number of the guide that you are looking at.

0.3 Copyright notice
Software and manual: © 2021 Windell H. Oskay, Evil Mad Science LLC
6.4 Using multiple Clip Easels ........................................... 27
6.5 Moving beyond the Clip Easel ........................................ 27
6.6 Magnetic easel accessories ............................................. 27

7. In detail: Power and USB .................................................. 28

8. In detail: Setting up pen and paper ..................................... 29
   8.1 Pen choices ............................................................... 29
   8.2 Setting the pen angle .................................................. 29
   8.3 Inserting a pen .......................................................... 30
   8.4 Pen up and pen down positions .................................... 31
   8.5 Positioning your paper ................................................ 34

9. Working with AxiDraw Control .......................................... 36
   9.1 Plotting the document .................................................. 36
      9.1.1 Number of copies ............................................... 37
      9.1.2 Delay between pages .......................................... 37
   9.2 Pausing, resuming, and canceling plots ......................... 38
      9.2.1 To resume after pausing ..................................... 38
      9.2.2 To return to the Home Corner after pausing ............ 38
      9.2.3 Canceling a plot ................................................. 39
   9.3 Plotting with multiple layers and colors ......................... 39
      9.3.1 Inkscape’s Layers panel ...................................... 39
      9.3.2 The Layers tab in AxiDraw Control ......................... 40
      9.3.3 An example with multiple colors ............................ 41
      9.3.4 Multiple copies from the layers tab ....................... 42
      9.3.5 Additional layer control features ............................ 42
   9.4 The Timing tab ......................................................... 43
      9.4.1 Suggested starting speeds .................................... 44
      9.4.2 Pen lift speeds .................................................... 45
   9.5 Advanced options ...................................................... 46
   9.6 Preview Mode ............................................................ 47
   9.7 Plot order and optimization ......................................... 49
      9.7.1 How plot order is determined ............................... 49
      9.7.2 The Plot optimization option ............................... 49
11.7 Hershey Text ................................................................. 69
11.8 Hershey Advanced and AxiDraw Merge .................... 70
  11.8.1 Hershey Advanced ................................................. 70
  11.8.2 AxiDraw Merge .................................................... 70
11.9 Capturing signatures and handwriting ..................... 71
11.10 Aside: Tracing of scanned handwriting ................. 71
11.11 Filling shapes and text ............................................. 72
11.12 Vectorizing images .................................................. 74

12. Maintenance and troubleshooting ............................ 76
  12.1 Troubleshooting plot area ...................................... 76
  12.2 No lubrication required ......................................... 76
  12.3 Cleaning ............................................................... 76
  12.4 Storage ................................................................. 76
  12.5 Belt tension .......................................................... 76
  12.6 The wrenches ....................................................... 76
  12.7 Wiring ................................................................. 77
  12.8 The pen-lift servo motor ....................................... 77
  12.9 Loss of position ..................................................... 77
  12.10 Service, repair, and parts support ......................... 77

13. AxiDraw Tips and Tricks ............................................ 78
1. Introducing the AxiDraw

The AxiDraw is a simple, modern, precise, and versatile pen plotter, capable of writing or drawing on almost any flat surface. It can write with your favorite fountain pens, permanent markers, and other writing implements to handle an endless variety of applications. Its unique design features a writing head that extends beyond the machine, making it possible to draw on objects bigger than the machine itself.

The AxiDraw is an extremely versatile machine, designed to serve a wide variety of everyday and specialized drawing and writing needs. You can use it for almost any task that might normally be carried out with a hand-held pen.

It allows you to use your computer to produce writing that appears to be handmade, complete with the unmistakable appearance of using a real pen (as opposed to an inkjet or laser printer) to address an envelope or sign one’s name. And it does so with precision approaching that of a skilled artist, and — just as importantly — using an arm that never gets tired.

1.1 Credits and History

The AxiDraw project has been active since 2014, when it was first created by Dr. Lindsay Robert Wilson of IJ Instruments Ltd. in the UK.

Early AxiDraw units had a different design. It had a smaller format with a chassis made from machined Delrin plastic. It had two independent timing belts, one driven by a stepper motor on the base, and the other by a stepper motor on the moving carriage. For software, it used a modified version of the WaterColorBot driver developed at Evil Mad Scientist.
AxiDraw V2

In 2015, Wilson began collaborating with Windell Oskay and Lenore Edman of Evil Mad Scientist Laboratories towards a new AxiDraw model that would be designed and manufactured in the USA.

This second-generation AxiDraw was enlarged to reach twice the travel area, to cover a full page of A4 or US Letter paper. Its geometry was changed to use a single drive belt, with two larger stepper motors stationary on the base. Its major components would now be made of aluminum (machined or stamped and folded), and the new pen holder could be mounted vertically or at 45° to the paper.

AxiDraw V3

The third generation, the AxiDraw V3 family, is a full redesign of the machine for higher performance.

While previous models had steel shafts and linear ball bearing slides, this new version features custom aluminum extrusions with rolling wheels. The vastly increased stiffness of the structures — without added weight — allow the machine to operate at significantly higher speeds and with higher precision than older geometries based around steel shafts.

2. Checking out your AxiDraw

2.1 Parts and accessories

Here are the parts that come with AxiDraw:

1. The AxiDraw itself
2. Clip Easel and binder clips (4 on AxiDraw V3, 8 on larger models)
3. Plug-in power supply
4. USB cable
5. Hex drivers and wrenches
   Sizes include 2 mm, 2.5 mm, and 3 mm hex drivers, and low-profile 8 mm and 10 mm wrenches. Of these, only the smallest (2 mm) hex driver is used in regular operation. The rest are normally not needed.
6. Rubber bands
   These can be used to add a little extra pen-down force if needed.
   See the last chapter, AxiDraw Tips and Tricks.
7. Not shown: Extra rubber feet (AxiDraw V3 and V3 XLX only)
   Normally not needed. But, just in case a rubber foot gets bumped off of the base during shipping, spares are included.
8. Not shown: Special accessories included with AxiDraw SE/A3
   The SE/A3 also includes an XL pen clip and an italic pen adapter.
   These are available separately for use with other AxiDraw models.

To learn more about available AxiDraw accessories, please visit: emsl.us/902
2.2 AxiDraw anatomy

Let us look at the different parts of the AxiDraw. We will refer to these parts by name throughout this guide. These features are common to each model of AxiDraw, though appearances may vary slightly. For example, the AxiDraw V3/A3 and SE/A3 have extended “outrigger” feet, and the AxiDraw SE/A3 base is colored black and covers the two motors.
Note: AxiDraw ships with its pen clip disconnected; see the next section.
2.3 Unboxing AxiDraw

The pen-lift motor cable and the pen clip are disconnected for shipping. Your first two steps, out of the box, are to re-attach these parts.

Locate the disconnected cable end on the left hand side of the base.

The cable has three wires: Black, red, and white.

Plug its connector into the bottom three pins on the EBB Control Board as shown. The black wire faces back, towards the edge of the board.
Thread the black plastic thumbscrew into the pen clip.

Attach the pen clip to the vertical slide with the two small black M3 screws, using the 2 mm hex wrench, which has a ball end for easier access. The pen clip may be attached either in a vertical or diagonal orientation, depending on what kind of a writing implement you are using.
The pen clip can be attached in two different positions: Vertical, which positions the pen straight down, or diagonally, which holds the pen at a 45° angle to the paper.

Aside: If you have an older AxiDraw...

First-generation AxiDraw V3 units had four threaded holes on the vertical slide and two holes in the pen clip (rather than two threaded holes and four holes on the pen clip.) If you have one of these machines, it looks a little different, but you still use the two screws to attach the pen clip in the vertical or diagonal position.
2.4 Safe handling of the AxiDraw

1). **Lifting**: Lift AxiDraw by the central strut of the base, or by the stepper motors if necessary. Do not lift by the cables, cable guides, carriages, or pen holder. The AxiDraw SE/A3 has a handle milled into the back of the central strut, to provide an additional lifting point in the middle of the machine.

2). **Heat**: Please note that the two stepper motors may get warm. This is normal, but it is helpful to be aware of it. They should not get too hot to touch.

3). **Moving parts**: AxiDraw has exposed moving parts. Keep fingers, hair, and other things that could get caught, crushed, or tangled safely away from the belt and the pinch points between the moving carriage, the pen holder, and the motor covers.

Warning: Keep fingers away from pinch points while AxiDraw is operating.
3. Software for AxiDraw

3.1 Installing software
You will need to install software on your computer to operate the AxiDraw. Current instructions and download links are available at: [http://axidraw.com/sw](http://axidraw.com/sw)

From there, follow the directions specific for your operating system:
- For Mac and Windows, there are easy installers that you can download.
- For Linux, one or more manual steps are required.

The software that you will install includes Inkscape, the superb (and free) drawing program, and a set of extensions that operate the AxiDraw from within Inkscape.

If you run into any difficulty while following along with the installation steps, please contact us for technical support —*we are here to help*. You can find our contact information on the back page of this user guide.

3.2 Inkscape and the extensions
Once you have installed the software, launch Inkscape. The AxiDraw software is located within the Extensions menu of Inkscape.

![Extensions menu](image)

There are two relevant items in the Extensions menu: **AxiDraw Control**, the primary software interface to AxiDraw, and the **AxiDraw Utilities** submenu, which contains several supplemental tools.

Later in this user guide, we will go into depth about the different features of the software and how to use it.
3.3 Aside: Alternative software, CLI, and APIs

The AxiDraw software is available in two alternate versions that may be helpful for developers or for anyone who would to control the machine programatically rather than through Inkscape. There is a stand-alone command-line interface (CLI) tool, as well as a full-featured python library. You can learn more about these tools at:


If you would like to directly interface to the AxiDraw’s EBB motor control board, it has a fully documented serial command protocol that you can control from any programming interface that can address your USB port.

RoboPaint is an alternative software package available for painting and drawing robots. It requires a separate install process, but does support AxiDraw. It also has a built-in REST API. There are also various other third-party software tools that can control the AxiDraw.

For more information about these alternatives, please see the documentation and links on our wiki site: http://axidraw.com/docs
4. Quick start: Making your first plot

In this section, we will briefly walk through the steps to make your first plot. After this section, we will discuss each part of this process in additional depth.

As you get started, please make sure that you have gone through §2.3 Unboxing AxiDraw, on page 12 (so that you have connected the pen-lift cable and installed the pen clip) and §3.1 Installing software, on page 16.

4.1 Pen, paper, and the clip easel

For your first plot, you’ll need a pen (or something else to write with) and paper (or something else to write on).

The easiest way to get started is to use the Clip Easel, a hardboard with binder clips, included with the AxiDraw. Clip a piece of paper to the top of it.

For more information about the Clip Easel and other methods of workholding, see §6. In detail: Workholding, on page 25.

4.2 Move to the Home corner

Prior to plotting, it is necessary to move the AxiDraw carriage to the Home Corner. This is where the carriage is as far left and as far back as it can go: where the pen holder is closest to the engraved label “Home”.
Once you have identified the Home Corner, slide the carriage there by hand.

You can move the carriage by the solid block of metal behind the vertical slide of the pen holder. (Do not push the vertical slide itself or the pen clip directly.)

If the carriage does not move easily, you may need to turn off the motors. To do so, select from the Extensions menu in Inkscape:

AxiDraw Utilities > Disable XY Motors

For more about the Home corner, please see §5. In detail: The Home Corner, on page 24.

4.3 Connect Power and USB

Next, connect the power and USB cables to the AxiDraw as shown below. Connect the USB cable to any available USB port on your computer, and plug the power adapter into a working outlet.

For more information about the power and USB cables, please see §7. In detail: Power and USB, on page 28.
4.4 Check pen-up and pen-down positions

Within Inkscape, open up AxiDraw Control: 
Extensions > AxiDraw Control. Then, select the Setup tab:

![AxiDraw Control interface](image)

Select the **Toggle pen between UP, DOWN** option, and click the **Apply** button. If everything is hooked up correctly, the pen lift motor should alternately move the vertical slide to the pen-up or pen-down positions each time that you press Apply.

If there is no movement, double check that you have power and USB connected as given in the previous section. If it still does not move, also check that you have correctly hooked up the pen-lift motor cable. (See §2.3 Unboxing AxiDraw, on page 12.)
4.5 Insert your pen

Starting with the AxiDraw in the pen-up position, insert your pen into the pen clip, just above the paper, and tighten it in place with the thumbscrew.

The vertical position of your pen should be approximately 1/8 to 1/4 inch (3 - 6 mm) above the surface of the paper.

Take care to only apply gentle force with the thumbscrew; do not tighten it more than necessary.

For more about pens and pen choices, see §8. In detail: Setting up pen and paper, on page 29.

4.6 Position your paper

With the carriage still at the home corner, position the upper-left corner of your paper directly beneath the tip of your pen, such that if your pen were to be lowered, it would touch the corner of the paper closest to the Home corner.

The photo above shows the paper positioned correctly, with its corner directly under the tip of a pen – in this case a fountain pen mounted at 45° to the paper.

For additional examples of paper positioning, please see §8.5 Positioning your paper, on page 34.
4.7 Open a document and print it

Download the set of AxiDraw example files from [http://axidraw.com/ex](http://axidraw.com/ex)

The download is a small zip archive of example files. Open (unzip) the archive. Then, within Inkscape, open up the file called `AxiDraw_First.svg`. Once open, the document should look approximately like this:

If you cannot see the full page outline when you first open the file, select from the menu **View > Zoom > Page**, or type the number ‘5’ on your keyboard.

Finally, open AxiDraw Control, switch to the **Plot** (first) tab of AxiDraw Control, and click **Apply** to begin the plot.
The AxiDraw should now begin printing your document, and will return back to the Home Corner, with pen up, when it finishes. With a black pen, it will look something like the following:

4.8 Recap: Setting up a print

Let us summarize the steps that we’ve been over:

1) Move the AxiDraw to its Home Corner.
2) Plug in power and USB.
3) Using the software, toggle the pen down and back up.
   • From the menu, select Extensions > AxiDraw > AxiDraw Control
   • In the Setup tab, use the Toggle pen between UP, DOWN option.
4) Clip in your pen, with height just above the paper.
5) Position your paper with its upper-left corner below the pen tip.
6) Using the Plot tab in AxiDraw Control, click Apply to plot the document.

The next few sections of this guide, §5-8, cover these same topics in greater detail.

4.9 Setting the machine size

One final tip as you get started: By default, the travel limits set in the software are those for the AxiDraw V3. If you are using an AxiDraw with larger travel, such as the AxiDraw V3/A3 or AxiDraw SE/A3, be sure to select your AxiDraw model in the Config tab of AxiDraw Control.

For more information, see §9.9 The Config tab, on page 55.
5. In detail: The Home Corner

Before you start plotting, the carriage must be moved to the **Home Corner**. This is as far left and as far back as it will go: where the pen holder is closest to the left side of the base, that is when the pen holder is closest to the engraved label “Home”, and the USB port.

When a plot finishes, the AxiDraw will return to its Home Corner automatically, leaving it ready for your next plot.

Slide the carriage to the Home Corner by hand. You can move it diagonally by holding the solid block of metal behind the vertical slide of the pen holder. Do not push the vertical slide of the pen holder directly.

The carriage should only be moved when the power to the motors is off. If it does not move easily, turn off the motors so that you are not trying to force them.

To turn off the motors, select **Extensions > AxiDraw Utilities > Disable XY Motors** from the menu in Inkscape. Alternately, you can use the “Raise pen, turn off motors” command in the Setup tab of AxiDraw Control (see page 31) or physically disconnect the AxiDraw from power.
6. In detail: Workholding

Whatever workpiece the AxiDraw is to write or draw upon – whether that is paper, boxes, wood, cloth, or cookies – needs to be held in place so that it does not shift while plotting.

6.1 Printing on large workpieces

For large workpieces such as a box or the poster board shown here, the AxiDraw may be placed directly on top of the workpiece. Other examples of large workpieces that AxiDraw can sit upon might include things like fabric, wooden surfaces, chalkboards or whiteboards.

6.2 Workholding with the Clip Easel

A Clip Easel, a simple hardboard with clips, is included with the AxiDraw for holding smaller workpieces – principally different shapes and sizes of paper – that are not large enough to be held down by the AxiDraw itself. This is a great way to mount paper when getting started with the AxiDraw.

The AxiDraw V3 Clip Easel is 9 × 12 inches (about 23 x 30 cm) in size, with rubber feet and small binder clips. (Larger easels are included with the larger-sized AxiDraw models.) You can mount different sizes of paper to it, including US letter size (or A4) paper, and smaller sizes including envelopes, cards, and invitations. With smaller paper, you can also potentially mount several pieces at the same time. The clips can be positioned as needed to hold the paper flat, and avoid the areas where you will be writing.
The examples shown above are:

A) A certificate to be filled out (Letter size, landscape orientation)
B) Mailing address (#10 envelope, landscape orientation)
C) A formal invitation (6 ⅜ × 8 ⅞ inch, portrait orientation)
D) A page of mixed text and drawing (Letter size, portrait orientation)

In every case, line up the corner of the paper with the upper left corner of the Clip Easel, such that the corner of the paper is closest to the Home Corner.

6.3 Document orientation

If your document is wider than it is tall (or square), it is said to be in landscape orientation, and your paper should be oriented as in examples A and B above. If your document is taller than it is wide, it has portrait orientation; and will print “sideways” as in examples C and D above. (This default behavior can be overridden; See “9.5 Advanced options” on page 46.)
6.4 Using multiple Clip Easels

A common technique is to use more than one clip easel, such that you can quickly swap out your completed workpiece for the next one. The key advantage is that one page can be plotting while you unclip and clip the next page. You can use tape marks or hard end stops on your table (like a carpenter’s square) to facilitate quick alignment.

A second method can be used when your workpieces are substantially smaller than the working area of your machine. For example, if you are labeling small note cards with the AxiDraw, or if you are plotting two side-by-side letter (A4) size pages with the AxiDraw V3/A3 or AxiDraw V3 XLX. Using two small easels side by side, you can designate one “A” and one “B”, and alternate plotting on the “A” or “B” side. If you change out each side when it finishes, you can plot continuously without ever pausing to swap out the paper.

6.5 Moving beyond the Clip Easel

While the Clip Easel is versatile, it is also entirely optional. Paper can be held in place with tape, clamps, tacks, paper clips, magnets, other types of clipboards, the weight of the AxiDraw itself, or by other means that you see fit.

If you only use one pen and paper size consistently, you may prefer to make a workholding solution tailored for your specific application. In some cases, making a fixture that is permanently mounted to a tabletop or work surface can save you a great amount of time.

6.6 Magnetic easel accessories

7. In detail: Power and USB

The power and USB cables connect to the AxiDraw as shown above.

Connect the USB cable to any available USB port on your computer. All AxiDraw models currently ship with a USB A to Micro-B cable. You can switch this out for other types of high-quality USB micro cables (e.g., USB C to Micro-B) as needed.

The plug-in power adapter included with the AxiDraw (9 V dc, regulated, center positive) works with worldwide mains power (100-240 V ac). Outside of the US, it may require an inexpensive plug-shape adapter. Do not use an adapter that changes the voltage.

Once your cables are connected, make sure that the AxiDraw has room to move, both in front of and behind the machine. Leave room for the Y axis to move, and take care that as the carriage moves (left to right, back and forward), it cannot get caught on stray cables.
8. In detail: Setting up pen and paper

In this section we will discuss different types of pens, configuring the pen angle, the pen-up and pen-down positions, setting the pen height, and how to set the paper position relative to the pen.

8.1 Pen choices

The pen holder included with the AxiDraw fits pens up to ⅝ inch (16 mm) in diameter. The maximum recommended pen weight is 1.6 oz (45 g). The design is such that the pen rests on the surface by its own weight. That allows it to ride over surfaces that are textured or otherwise uneven, however it also means that the pen holder does not apply much if any downward pressure.

Good choices for pens include fountain pens, permanent markers, rollerball pens, technical pens, (small-bodied) whiteboard markers, liquid chalk markers, and other writing and drawing instruments that do not require significant pressure. While we refer to writing and drawing instruments as “pens” to be concise, other instruments such as automatic pencils, chalk, charcoal, and brushes can also work well in many cases. Others, like traditional ball point pens, may work poorly because they require a substantial amount of downward pressure to operate.

8.2 Setting the pen angle

The pen may be mounted vertically or diagonally at 45° to the paper by mounting the Pen Clip in either the vertical or angled position.

To detach the pen clip, loosen and remove the two black M3 screws on the front of the pen clip, using the 2 mm hex wrench, which has a ball end for easy access. Use the same two screws to reattach the pen clip, either in the vertical or diagonal orientation.
The 45° angle position is ideal for use with fountain pens, but will work well with most rollerball and fine point markers. The vertical position is more suited to markers with fatter tips or writing instruments that require more downward pressure. The vertical orientation is also the best choice when making plots that require you to swap pens – for example when making multicolor plots.

### 8.3 Inserting a pen

You can insert a pen – or other writing instrument that you are using – into the pen clip and tighten it in place with the thumbscrew.

Take care to only apply gentle force with the thumbscrew: You need merely to immobilize the pen; stop tightening it once you encounter moderate resistance. If the vertical slide does not move freely up and down, the first thing to check is to make sure that you aren’t holding the pen too tightly.

When using any ink-based pen (whether rollerball, fountain pen, or permanent maker), it is helpful to “bleed” out the tip before writing. Try it by hand on a piece of scratch paper, and make sure that ink is actually flowing.

*Aside: Fragile or delicate pens:* If you choose to use fragile pens (such as high-end fountain pens with celluloid barrels), exercise great care when inserting the pen. You may wish to wrap the barrel in a thin, soft cloth to avoid scratching, and use little or no pressure from the thumbscrew. Moderately priced fountain pens, like the Lamy Safari or the Pilot Metro shown above, tend to be quite tough, and require little special treatment.
8.4 Pen up and pen down positions

In this step we will check the pen-up and pen-down positions.

Within Inkscape, open up AxiDraw Control: Extensions > AxiDraw Control. Then, select the Setup tab:

Select the Toggle pen between UP, DOWN action, and click the Apply button. If everything is hooked up correctly, the pen lift motor should alternately move to the pen-up or pen-down positions each time that you press Apply.
If there is no movement, double check that you have power and USB connected as given in the previous section. If it still does not move, also check that you have correctly hooked up the pen-lift motor cable. (See section “2.3 Unboxing AxiDraw” on page 12.)

While in the pen-up position, insert your pen and position it above your paper.

The vertical position of your pen should be approximately 1/8 to 1/4 inch (3 - 6 mm) above the surface of the paper. You can physically adjust the position of the pen with the thumbscrew, and/or change the positions from the Setup tab of AxiDraw Control.

Toggle also to the pen-down position. With the pen down, the pen should rest on the paper by its weight. If it does not, you may need to lower the pen-down position. (While testing, you can protect the paper that you will be writing upon with another sheet of paper, to avoid writing on your actual workpiece.)

Finally, return the pen holder back up, to position your paper for printing.
Once you are familiar with the process of inserting the pen and setting the height, this whole process is described by two quick steps:

1) Raise the pen holder to the pen-up position.
2) Insert your pen, just above the paper.

The pen-up and pen-down heights in the Setup tab may each be adjusted between 0 and 100% to suit your needs. Higher percentage values lift the pen higher.

The factory-default values of 60% (up) and 30% (down) are a good starting point. You may also wish to try adjusting them to a different set of values (say, 80% and 50%, respectively) and apply, to see that the positions change when you adjust them and toggle the pen position.
8.5 Positioning your paper

With your pen at the Home Corner, and the pen at an appropriate height, it is time to position the paper with respect to the AxiDraw. The printable area starts at the Home Corner, and extends down and to the right from that point.

Plotting on large surfaces (where the AxiDraw sits directly on the surface): Position the AxiDraw such that the pen tip is at the upper left corner of the area that you intend to plot upon. The software will treat the corner of the page in your Inkscape document as Home Corner for the purpose of plotting.

Here is how the “page” printed above looks from within Inkscape:
Plotting on everything else (letters, envelopes, invitations, and smaller items): Position the paper with its upper-left corner directly underneath the tip of the pen. Square the paper up so that its top edge is parallel to the base of the Axi-Draw.

As we discussed earlier (page 26), documents that are taller than wide are usually turned “sideways”, as in B above. Whether vertical or horizontal, it is always the corner of the paper closest to the Home Corner that one aligns below the tip of the pen.

For comparison, here are how those two documents look on the computer when setting up to print:

The absolute position of your paper with respect to the AxiDraw will vary, depending on the paper, the pen that you use, as well as the pen length if it is mounted at 45°. For any given pen and paper setup, it is likely to remain relatively consistent. (See §6.5 Moving beyond the Clip Easel, on page 27.)
9. Working with AxiDraw Control

In this section we will introduce the features and options in AxiDraw Control, the primary interface to the AxiDraw. It can be found within your Inkscape menu at Extensions > AxiDraw Control

AxiDraw Control has a tabbed interface, where the different tabs contain different settings or control different functions.

9.1 Plotting the document

To plot your document, select the Plot tab and click Apply. This will plot the entire document, including all visible layers.

The Plot tab contains two options: Copies to Plot and Seconds of delay between copies, which are used when plotting multiple copies of the same document.

If the Copies to Plot parameter is set to a value greater than 1 (the default), then the AxiDraw will plot the document that number of times, with an optional delay between copies.

This is a particularly helpful feature when using AxiDraw as a signature machine, or for similar quick repeating tasks: you can have the machine sign each document with just a time delay between documents.
§9.1 Plotting one or more copies, continued

9.1.1 Number of copies
Enter the number of copies that you would like to plot in the Copies to Plot box. The default value, 1 copy, will only plot the page once.

As a special case (and noted as a “Tip” on the Plot tab), setting the number of copies to 0 (zero) will cause the AxiDraw to plot continuously, with the given delay between pages, until you press the physical pause button on the left side of the AxiDraw. (See §9.2 Pausing, resuming, and canceling plots, on page 38 for more about pausing.)

If you do use this continuous plotting mode, we recommend that you press the pause button during the delay between plots, while the AxiDraw is resting at the home position.

9.1.2 Delay between pages
The value of Seconds of delay between copies sets how long the AxiDraw will pause between pages when plotting multiple copies. This delay is intended to allow time for you to swap out the paper between copies. The default value is 15 seconds, but it can be set anywhere from 0 (no added delay) to 3600 seconds (1 hour).

Applicability of multiple copies:
These two parameters, Copies to Plot and Seconds of delay between copies, apply only when plotting the document from the Plot or Layers tabs. They have no effect on other functions.
9.2 Pausing, resuming, and canceling plots

To stop a plot in progress, press the pause button: the raised silver-colored button located on the left hand side of the AxiDraw. (See the pictures on page 11.) The AxiDraw will stop plotting and raise the pen after finishing the current line segment. The plotting progress is saved within your document.

**Note:** You must *physically press the pause button* to stop a plot in progress. (Inkscape has a “Cancel” button, but it does not stop running extensions.)

Once paused, you can make adjustments in the settings (for example, to the pen height or plotting speed), before resuming, if you choose to do so.

### 9.2.1 To resume after pausing

To resume a plot after pausing, open the **Resume** tab of AxiDraw Control, select the **Resume** action and click **Apply**.

![AxiDraw Control Resume Tab](image)

### 9.2.2 To return to the Home Corner after pausing

To return the carriage to the Home Corner, select the **Return to Home Corner** option and **Apply**. The plot can still be resumed after moving back to Home (if, and only if, moved by this command).
9.2.3 Canceling a plot

It is not necessary to take any action to cancel a plot that has already been paused. However, if you wish to start a new plot, you do still need to return the carriage to Home before beginning a new plot.

You can return the carriage home using the Resume tab (as described above) or manually.

If you need to move the carriage Home by hand, remember to unlock the motors so that the carriage can be moved. To do so, you can either use the dedicated utility at AxiDraw Utilities > Disable XY Motors or select the Setup tab in AxiDraw Control and use Raise pen, turn off motors.

9.3 Plotting with multiple layers and colors

By default, the AxiDraw will print all visible paths in your document. A document can, at your option, be organized into multiple layers. When you use the Plot tab to print a document with multiple layers, each visible layer will print, and the order of printing is from lowest layer first to highest layer last.

You can also use AxiDraw Control to plot a single layer, or some specific set of layers. These methods are particularly useful for organizing and plotting documents that require multiple pens and/or colors.

9.3.1 Inkscape’s Layers panel

To create layers and move objects between them, you can use the commands in Inkscape’s Layer menu. You can also open the Layers panel (shown at right) by selecting from the menu:

Layer > Layers...

Within the Layers panel, you can add, remove, re-order and rename layers. The little “eye” buttons, to the far left of the layer names, are used to hide and show individual layers. Hidden layers will not be printed, and this is one of the simplest ways to select only certain parts of your document to print.
9.3.2 The Layers tab in AxiDraw Control

A second method of using plotting specific layers is to use the Layers tab of AxiDraw Control:

The Layers tab of AxiDraw Control has a single numeric input field, labeled Plot only layers beginning with. When you click Apply with the Layers tab active, the AxiDraw will plot only the layer or layers that have a name beginning with the number entered in that field. To use it, give your layers (that you wish to print this way) names that begin with an integer in the range 0 through 1000.

After plotting your chosen layers from the Layers tab, you can change any settings that you wish to, or switch to a different pen. This makes it possible to plot drawings with portions drawn with different colors and (for example) different speeds.

To give a more concrete example, if you have three layers with the names,

1 - Red circles
2 - Blue stars

Then, you could plot the two red layers with a red pen by specifying “1” in the Plot only layers beginning with field. You can then change the pen to blue and plot the blue layer by specifying “2” in that field. Click the Apply button each time to begin plotting of the selected layers.
9.3.3 An example with multiple colors

The set of layers shown in the Layers panel here page corresponds to the example below: A birth-
day party invitation with six colors and six layers. We have used the layer numbering scheme from the previous section.

You can see how it appears in Inkscape (top), as well as printed on the page (bottom) using six ultra-fine point Sharpie markers, one per layer.
9.3.4 Multiple copies from the layers tab

The Copies to Plot and Seconds of delay between copies parameters in the Plot tab do apply when you plot from the Layers tab. That means that you can plot the same layer or set of layers multiple times, in the same fashion as plotting multiple copies from the Plot tab. (See §9.1 Plotting the document, on page 36).

9.3.5 Additional layer control features

Beyond control with the Layers tab, there are additional commands and parameters that can be specified through the layer name.

You can use properly formatted codes to specify the pen-down height and the speed for printing specific layers. There are also special codes that can introduce a timed delay while plotting or force a programmatic pause (as though you had pressed the pause button to halt a plot). These types of codes are rarely used in everyday plotting, but can be useful in developing specialized applications.

One additional, and particularly useful, feature is that any layer with a name starting with a percentage sign “%” is designated as a documentation layer, and will not be plotted.

The Layer Control features are always active, and can be used (for example) whether you are plotting from the Plot or Layers tab of AxiDraw Control.

The complete syntax for AxiDraw Layer Control can found at: https://wiki.evilmadscientist.com/ALC
9.4 The Timing tab

The **Timing** tab of AxiDraw control lets you set the basic movement speeds for the AxiDraw. The three parameters at the top under **Movement speeds** set the speed limits and acceleration rates used for the horizontal (XY) carriage motion.

Clicking the **Apply** button with the **Timing** tab selected has no effect; you can change settings here, but it does not initiate a plot or any other function.

The first item in the list, **Writing/Drawing speed**, sets the maximum speed that will be developed when the pen is down. The second, **Pen-up movement speed**, sets the maximum speed that will be used when the pen is up, traveling between two points.

The default value for these two speeds are 25% and 75%, respectively. You can adjust these speeds. Keep in mind that – just like writing by hand – there will always be a trade-off between speed and neatness.

The **Acceleration** parameter controls how quickly the pen will approach these maximum speeds, and is at least as important as the speed limits in determining the total time that a plot will take.
9.4.1 Suggested starting speeds

**Everyday use:**
Most of our sample drawings and tests are made with a medium speed that is a compromise between speed and precision. This is a good balance for fine-point permanent markers and wide-nibbed fountain pens:
- Writing/Drawing speed: 30%
- Pen-up movement speed: 75%
- Acceleration: Standard

**Working with precision:**
When working with fine point pens and tuning for higher precision (with writing or drawing) a good starting point might be:
- Writing/Drawing speed: 15%
- Pen-up movement speed: 60%
- Acceleration: Slow

**Working at high speeds:**
When using wide-tipped permanent markers or other writing implements that make broad marks, one might go as high as:
- Writing/Drawing speed: 90%
- Pen-up movement speed: 100%
- Acceleration: Maximum

There are additional factors besides speed that influence precision. These factors include the pen lift and lowering speeds, the weight of your pen, where on the page you are plotting, and so forth. The “right” speed to use for any given application is one that gives you high enough output quality at an acceptable rate.
9.4.2 Pen lift speeds

The lower half of the Timing tab has a heading Pen lift and lowering speeds. These parameters control the vertical motion between the heights that are set in the Setup tab (page 31).

The pen raising and lowering speeds can each be selected from a pop-up menu, with options Maximum, Standard, Slow, or Very slow.

The AxiDraw will pause its horizontal motion while raising or lowering the pen, until the vertical movement is complete. These pauses are meant to prevent the machine from making pen-up movements until the pen is actually clear of the paper, and to prevent pen-down movements from beginning until the pen is touching the paper.

If you are trying to increase the speed of your plots, be aware that the total vertical travel distance is a very important factor in how long pen lifting and lowering takes. Thus, try to decrease the vertical range first, and look at the delays next.

Slower, gentler movements are possible, and will both lead to neater writing and prolong the life of the pen-lift motor as well as your pen tip.

You can optionally add an additional delay after raising or lowering the pen, to adjust the behavior of one or both of these vertical motions. However, in most use cases, these delays should be kept at zero; adjusting the pen height positions and/or the physical location of the pen is preferable and does not add duration.
9.5 Advanced options

You can use the Options tab of AxiDraw Control to set options that affect plots initiated in other tabs. As with the Timing tab, pressing the Apply button with the Options tab selected has no effect. (This tab on its own does not initiate a plot, run a plot preview, report time estimates, perform plot optimizations, or any other function.)

Auto-rotate page when printing (Default: on)
Documents taller than wide (those in portrait orientation) are normally rotated sideways when plotted. (See §6.3 Document orientation, on page 26 for examples.) To force documents to always print in the same orientation as on your screen, uncheck this box.

Use constant speed when pen is down (Default: off)
When checked, disable acceleration and move the pen at a constant speed when it is down. This will give neater performance for certain types of paths, but creates more vibration when going around curves. It gives more uniform but less “natural” ink flow.

Report time elapsed (Default: off)
When checked, a dialog box will report the elapsed time and pen-travel distance after each plot finishes. This option is particularly useful in preview mode.

Plot optimization (Default: None; preserve file order):
If enabled, elements in the document may be re-ordered to reduce plotting time. This option is discussed in §9.7 Plot order and optimization, on page 49.
Motor resolution (Default: ~2870 DPI)

The two options are for native resolution of about 1435 or 2870 steps per inch (56 or 113 steps per mm). Both options are finer than what can be resolved with pens. The 1435 DPI option is slightly faster, while the 2870 DPI option is slightly smoother, giving a neater plot. The difference between the two settings is typically minor in practice.

9.6 Preview Mode

An additional feature located in the Options tab is offline preview mode. When preview mode is enabled, it will cause the AxiDraw software to simulate plotting only. That is to say that everything will work normally, with the significant exception that the software not attempt to communicate with the AxiDraw over USB.

![Preview mode settings](image)

Preview mode can be useful to test workflows or see how the AxiDraw will handle a document, even without the AxiDraw present. To run a plot preview, enable the option and then press Apply on the Plot, Layers, or Resume tab to initiate a plot as you normally would. (Again, pressing Apply on the Options tab has no effect.)

An option available in preview mode is Preview mode rendering. Preview mode rendering can be enabled from a drop-down menu, with options None, Pen-down movement, Pen-up movement, and All movement. If an option other than None is selected, then the selected portion of the plot (pen-down movement, pen-up movement or both) will be simulated and drawn on your page in a non-printing “documentation” layer when you run the preview. (For more about documentation layers, see “9.3.5 Additional layer control features” on page 42.)

If you have chosen to render a preview, then you can use the Layers panel (available in the menu at Layer > Layers...) to hide, show, or remove the preview layers. Each time that you render a new preview it will overwrite the old one.

Preview mode rendering is only available when preview mode is enabled.

If the Report time elapsed option is enabled when you simulate plotting, then the software will provide an estimate of the total plotting time.

Certain modes and commands that are primarily designed to communicate with the AxiDraw over USB — including those in the Setup and Manual tabs — are unavailable while in preview mode.
Here is how the example file AxiDraw_First.svg renders when you click Apply from the Plot tab with preview mode enabled and the All movement preview mode rendering option selected:

The pen-down movement is shown in blue, and the pen-up movement is shown in light red.

And, here is how those previews appear in the Layers panel:

The pen-down drawing and pen-up drawing are rendered as separate sublayers within the Preview layer, so that you can hide one, the other, or both. Since they are documentation layers, these layers will not plot on the AxiDraw, nor will their contents be rendered as part of future preview renders.
9.7 Plot order and optimization

The **Plot optimization** option in the **Options** tab can re-order elements in your document to reduce pen-up travel, and thereby reduce total plotting time.

9.7.1 How plot order is determined

In normal use, and by default, elements within a document are plotted in the same order in which they appear in the file. This order is generally the order in which the objects were created; it might also be referred to as “bottom to top.”

For example, suppose that you draw a circle and then a rectangle. Then, when you plot the file, the AxiDraw will plot the two objects in the order that you created them: The circle will plot before the rectangle.

The rectangle in this example can also be described as being “above” the circle— a description that makes sense if you imagine painting one object and then painting the other on top of it.

You can use the tools in the **Object** menu to rearrange the order of objects, for example with the **Object > Raise** and **Object > Lower** menu commands. If you raise our example circle above the rectangle, then the rectangle will plot before the circle.

If a document has multiple layers, lower layers are plotted before higher layers.

9.7.2 The Plot optimization option

The **Plot optimization** drop-down menu in the **Options** tab has three items:

- **None; preserve file order** (default)
- **Basic; preserve groups**
- **Full; ignore grouping**

By default, plot optimization is disabled, and objects in the document will be plotted in the order given by the file. However if either “Basic” or “Full” is selected, then elements within the file will be reordered to reduce pen-up travel when you run a plot or plot preview from the **Plot**, **Layers**, or **Resume** tab. Detailed descriptions of the options can be found in the sections that follow.
The optimization routine is layer-aware: It will only re-order objects within layers. That makes it safe to use on multicolor plots where colors are separated by layers. (See §9.3 Plotting with multiple layers and colors, on page 39.)

Any changes made to the order of elements in the file by the Plot optimization feature are ephemeral. A temporary copy of the file is created and re-ordered when you plot; no changes to the order of elements in your file are retained.

A separate stand-alone optimization utility is provided as well; please see §10.5 Plot Optimization, on page 60.

9.7.3 Default option: No reordering

If the default option, \texttt{None; preserve file order} is selected, then the document will plot in the order given by the file. No re-ordering is performed.

9.7.4 Reorder but preserve groups

If \texttt{Basic; preserve groups} is selected, the plotting order of objects within your document (including the order in which groups are plotted) may be altered to reduce pen-up travel time. However, if your document contains any groups of elements, the order of elements within those groups will be preserved. This option can be useful if you have groups that you wish to preserve the plot order within — for example if you have a line of text that plots left-to-right — but otherwise wish to speed up plotting of the document.

9.7.5 Full reordering

If \texttt{Full; ignore grouping} is selected, then all elements within each layer of your document will be re-ordered for speed, just as though you had ungrouped all elements before plotting.
9.7.6 Optimization tips and an example

When managing complex plots, it may be helpful to use preview mode (see §9.6 Preview Mode, on page 47) with rendering of pen-up travel enabled and the report time elapsed option, in order to preview what the plot order looks like and estimate the plotting time.

Here is an extreme example: a stipple plot, created with StippleGen, consisting of 2000 filled circles and laid out on a letter-size sheet of paper. To make this a “worst case” example, the stacking order of the stipplest within the file has been randomized, such that there is no particular order to which the filled circles appear in the file.

If we now enable preview mode with pen-up travel rendered (and plot optimization off), and run a preview using the Plot tab, we get the following utter mess, where the red lines represent pen-up travel:
The time report from this plot reads as follows:

- Estimated print time: 37:14 (minutes, seconds)
- Length of path to draw: 16.26 m.
- Pen-up travel distance: 253.35 m.
- Total movement distance: 269.61 m.

As you can see by the numbers and the pen-up travel (shown in red), this plot is dominated by pen-up travel. Only about 6% of the travel is with the pen down.

If we now enable plot optimization, selecting “Full” reordering and go back to the Plot tab to run the plot, we get the following, much more pleasing result:

With optimization enabled, the statistics are as follows:

- Estimated print time: 19:03 (minutes, seconds)
- Length of path to draw: 16.26 m.
- Pen-up travel distance: 10.96 m.
- Total movement distance: 27.22 m.

Thus, with the option enabled, this particular plot now takes about half the time: 19 minutes instead of 37.

**Aside:** While this is an extreme example, some real-world documents can exhibit this level of initial disorder, for example when you start with scanned and traced artwork, or documents generated programatically.
9.8 Manual Controls

The **Manual** tab of AxiDraw Control allows you to manually execute several basic commands and utilities. Select the operation to perform from **Command** drop-down menu, and then click the **Apply** button. For the two motor “walk” commands, you can also specify the distance to move the AxiDraw carriage.

The **Command** drop-down menu has a number of options, which are detailed in the following sections.
9.8.1 Walk Carriage (X, Y, inches, mm)
These four commands will move (“walk”) the carriage in the X or Y direction by a numeric distance given in the Walk distance field. The Walk distance may be positive or negative, and you can select either inch or millimeter units by choosing the appropriate command.

The Home Corner is the X=0, Y=0 position, and positive moves in both X and Y are away from the home corner.

Note that no limit checking is performed when manually commanding a move from the Manual tab. Take care not to run the AxiDraw into its physical limits. If you are unsure, disable the motors and move the carriage Home by hand.

9.8.2 Raise the Pen, Lower the Pen
These two commands move the pen to the pen-up or pen-down position.

9.8.3 Enable XY Motors, Disable XY Motors
These two commands either energize the two stepper motors or turn power off to them. The carriage can be moved by hand only when the power to these motors is off.

9.8.4 Enter EBB Bootloader Mode
Command the EBB to enter “bootloader” mode. This utility mode is sometimes used in reprogramming the firmware. If you should accidentally enter this mode, disconnect the AxiDraw from both power and USB to reset it.

9.8.5 Strip plotter data from file
The AxiDraw software stores certain configuration data within your document. While having that data there does not cause any known issues, this command can strip that data from the file, should that need arise.
9.9 The Config tab

The Config tab of AxiDraw Control allows you to specify which model of AxiDraw hardware you are using, specify which particular AxiDraw to plot to (if you are managing multiple machines), and check for software updates.

9.9.1 Selecting your AxiDraw model

Use the AxiDraw model drop-down menu to select which AxiDraw model you are using. If you are using one of the larger models, be sure to select that model from the pop-up menu in order to access the full plotting area of the machine.

Options in the AxiDraw model pop-up menu:

- AxiDraw V2 or AxiDraw V3
- AxiDraw V3/A3 or SE/A3
- AxiDraw MiniKit
- AxiDraw V3 XLX

If you have a custom-sized AxiDraw, please contact technical support for a custom configuration tailored to the size of your machine.
9.9.2 Machine selection

There are two additional controls in the Version tab that are useful when working with multiple AxiDraw machines: the **Machine selection** pop-up menu and the **AxiDraw name or port** text input box.

![Machine selection](image)

The **Machine selection** pop-up menu has three options:

- **Use First AxiDraw located** (default)
- **Use AxiDraw named below**
- **Plot to all AxiDraw units**

If **Use First AxiDraw located** (the default option) is selected, AxiDraw Control will control the first AxiDraw located via USB. Keep this option selected if you are working with a single machine.

If **Use AxiDraw named below** is selected, AxiDraw Control will only look for and drive a specific AxiDraw unit, as entered in the **AxiDraw name or port** entry box. Use this method when you have multiple AxiDraw machines and want to plot to a specific machine.

The name or port may be specified with a **USB nickname** – like “California” as entered above – or with a traditional enumerated serial port name like “COM6” on Windows or “/dev/cu.usbmodem1441” on a Mac. Since serial port names can change, it is best practice to use a USB nickname when possible. (For more about USB nicknames, see §10.1 AxiDraw Naming, on page 58.)

If **Plot to all AxiDraw units** is selected, a document that is plotted will be simultaneously sent to all detected AxiDraw units. Use this option when you have multiple AxiDraw machines and wish to plot the same document, simultaneously, on multiple machines.

When plotting the same document to multiple machines, any individual unit can be stopped by pressing its physical pause button, but plots that are stopped generally cannot be resumed.
9.9.3 Check for updates

If you click Apply with the Config tab selected, it will query and report both the versions of the AxiDraw software and the version of the AxiDraw “EBB” firmware. Additionally, this function will check online to see if newer software versions are available.

If your software version is earlier than the version that this user guide is written for (2.7.0), we do highly encourage you to update to the latest version.

As of the most recent edition of this user guide, AxiDraw is shipping with firmware version 2.7.0. If your EBB firmware version older is than 2.4.6, we do advise that you update to a newer version. Please visit http://AxiDraw.com/fw for more about updating firmware.
10. AxiDraw Utilities

In addition to AxiDraw Control, there are several additional utilities available in the menu under Extensions > AxiDraw Utilities.

10.1 AxiDraw Naming

The AxiDraw Naming utility allows you to assign a **USB nickname** to a specific AxiDraw. A USB nickname is a semipermanent label, stored in the AxiDraw’s flash memory, that may be used to identify and address it.

Nicknames are not required, but can be helpful if you have more than one AxiDraw connected: You can use them to specify which AxiDraw to plot to when using AxiDraw Control.

It can be found in the menu at Extensions > AxiDraw Utilities > AxiDraw Naming.
10.1.1 Read AxiDraw Name

If you click **Apply** with the “Read AxiDraw Name” tab selected, it will search for all attached AxiDraw units and list them for you. AxiDraw machines will be listed by their USB nickname or by their USB port enumeration, if no nickname has been assigned. This tool can be useful for listing available AxiDraw units, even if you are not using USB nicknames.

10.1.2 Write AxiDraw name

The second tab, “Write AxiDraw Name,” is for assigning a USB nickname. To assign the USB nickname, enter a name between in the text box (here “California”) and click **Apply**. Before writing the name, it is recommended that you disconnect any other connected AxiDraw units, so that you can be sure of which AxiDraw you are communicating with.

Writing an empty name will clear the nickname.

You can use the “Read AxiDraw Name” tab to verify that the name has been written correctly.

Assigning USB nicknames requires that your AxiDraw has firmware version 2.5.5 or newer. If you are unsure what version you have, you can check with AxiDraw Control; see §9.9.3 Check for updates, on page 57.
10.2 Disable XY Motors
This is a single-purpose “shortcut” command that turns off power to the pair of motors that controls the XY position of the AxiDraw carriage. This motor power is off by default at power up. It is often useful to turn off power to the XY motors so that the carriage can be manually moved to the home corner, prior to plotting.

It can be found in the menu at:
Extensions > AxiDraw Utilities > Disable XY Motors.

This command is equivalent to using the Manual tab in AxiDraw Control, with the Disable Motors command selected. (See §9.8 Manual Controls, on page 53.)

This shortcut command is intended for use with a single AxiDraw; it performs the action on the first AxiDraw located via USB. If you need to perform this action with multiple AxiDraw units, use the Manual controls in AxiDraw Control.

10.3 Hatch Fill
The Hatch Fill utility can be found in the menu at:
Extensions > AxiDraw Utilities > Hatch Fill

Its usage is described in §11.11 Filling shapes and text, on page 72.

10.4 Hershey Text
The Hershey Text utility can be found in the menu at:
Extensions > AxiDraw Utilities > Hershey Text

Its usage is described in §11.7 Hershey Text, on page 69.

10.5 Plot Optimization
This utility can be found in the menu at:
Extensions > AxiDraw Utilities > Plot Optimization

This is a stand-alone version of the plot optimization option in AxiDraw Control, described in detail in §9.7 Plot order and optimization, on page 49. It changes the order in which elements will be plotted, so as to reduce pen-up travel.

Unlike the option built into AxiDraw Control, which only temporarily re-orders the document, this stand-alone version changes the order of objects within the file so that you can save the optimized version. This approach may be advantageous if you plan to plot the same file many times.
There are three options available for how groups should be handled:

- **Reorder within groups** will re-order objects and groups within each layer of your document. Grouped objects will remain grouped. But, objects (and other groups) within any given group will be re-ordered.

- The second option, **Preserve groups** is similar to the Basic; preserve groups optimization option within AxiDraw Control. Elements and groups within any given layer will be re-ordered, but the order of elements with groups will not be altered.

- The third option, **Break apart groups**, is similar to the Full; ignore grouping optimization option within AxiDraw Control. If selected, then all elements within each layer of your document will be ungrouped and then re-ordered for speed. *This option removes the groups from your file.*

If you wish to visualize the pen-up travel and/or estimate the time that a plot will take, you can do so with preview mode within AxiDraw Control: See “9.6 Preview Mode” on page 47.
11. Designing for AxiDraw

11.1 General considerations

The AxiDraw is a *pen plotter*, which is fundamentally a single function device. Its sole function is to guide a pen (or other implement mounted in the pen holder) along the set of vector lines, curves, and paths that you ask it to follow. All other things that the machine is ultimately capable of – such as drawing graphics, writing text, or signing documents – are expressions of this basic function. It is capable of drawing essentially anything that can be composed from a set of lines.

Certain object types are automatically treated as paths, for example circles and rectangles. Other types of objects that are made of curves – like text – may need to be converted from (editable) text into simple paths before plotting. You can convert a selected object to a path by using the menu option *Path > Object to Path*.

11.1.1 Objects that are not paths

The AxiDraw does not directly plot objects that are not made of paths. This includes pictures (raster or bitmap images, such as JPG, GIF, and PNG files), and effects such as fills, gradients, and background colors. These kinds of things require conversion to paths before plotting. That is straightforward in some cases, and not in others.

Two notable helper tools are the Hatch Fill extension (see §11.11 Filling shapes and text, on page 72) and the various tools for converting images into sketches (see §11.12 Vectorizing images, on page 74).

11.1.2 Importing graphics

The native file format of the AxiDraw software is SVG (“scalable vector graphics” – a standard interchange format). You can create artwork directly in Inkscape or use other programs that can export SVG directly, such as Adobe Illustrator or CorelDRAW. Inkscape can also import artwork in formats including EPS, DXF, AI, CDR, and PDF.

If you encounter difficulties opening SVG documents into Inkscape, one approach that can help is to start with an empty document in Inkscape, and then use the *File > Import* command to place your document. See the next section, §11.2 Templates, on page 63, for more about empty documents.

It is worth noting that the file type itself is not always a reliable indicator of whether or not the file suitable for use on the AxiDraw. For example, a PDF document with vector paths from Adobe Illustrator will generally work very well, but it is also possible to create a PDF that contains nothing but a picture in JPG format. In the latter case, the image still isn’t vector graphics, even though it’s tucked into a PDF file.
11.2 Templates

When designing in Inkscape, it is recommended to create new documents by using a template, for example an A4 or US Letter sized document. You can create a basic document from a template by selecting **File > New from Template**, selecting **Page** from the left-hand list and then select your page size.

For other page sizes (not available within this panel), go to **File > Document Properties** after creating your document. There, you can find a long list of standard paper sizes that you can choose from.

If you frequently use page sizes that are not available in the Templates list, you may wish to save blank documents to use as your own templates.
11.3 Visualizing paths in your document

To see all of the paths in your document, select all in your drawing (From the menu: Edit > Select all in all layers). Then, open the Fill and Stroke panel (Object > Fill and stroke).

In the Fill tab, select “No paint” (the “X”). In the Stroke paint tab, select “Flat Color”. And, in the Stroke style tab, select a consistent width, say 0.020 inches or 0.5 mm.

This procedure generally provides a good preview of how the AxiDraw will view your page. It is only a preview, not a precise representation of how plotting will work. For example, it shows the outlines around objects even if they are not yet converted to paths.

For a more exact preview of how your document will plot, you may wish to try preview mode with rendering enabled, see §The two options are for native resolution of about 1435 or 2870 steps per inch (56 or 113 steps per mm). Both options are finer than what can be resolved with pens. The 1435 DPI option is slightly faster, while the 2870 DPI option is slightly smoother, giving a neater plot. The difference between the two settings is typically minor in practice., on page 47.
11.4 Fonts, characters, and languages

To reiterate, the AxiDraw is designed to trace the vector paths that you provide to it. The document that you prepare may include any number and variety of different text and graphical elements, so long as they are converted to paths before you plot them.

As its sole function is to follow paths, the AxiDraw itself does not use fonts (built-in or otherwise) nor does it have knowledge about any written languages. Thus, it has no preference for one language over another, and is equally happy to write in English, Japanese, or Arabic, so long as you can provide suitable input. Similarly, you can use fonts in any typeface style or character set – including international languages and including fonts that resemble handwriting.

Most fonts (e.g., TrueType, OpenType fonts) that are installed on your computer are accessible directly from within Inkscape. You can create and edit text objects in Inkscape by selecting the text tool, which you can select by clicking the icon shown here, or by using F8 on your keyboard. You can select between available fonts using the Text and Font panel, accessible in the menu at Text > Text and Font. 

To convert your editable text into paths that can be plotted, select them and choose from the menu Path > Object to Path. You may wish to save a separate copy of your document before converting to paths, in case you wish to edit the text again later.

This example was made using the font “Savoye LET” on a Mac.
11.5 About outline fonts

All standard computer fonts — those found in formats including TrueType, PostScript, and OpenType — are **outline fonts**. In outline fonts, each character in the font file describes a vector outline shape, which will be filled in by tiny pixels when displayed on your screen or rendered by an inkjet or laser printer.

Things are different when you wish to use a pen plotter. As described in the previous section, you can easily convert outline font text into a set of paths for plotting, and then plot it with the AxiDraw. When you do so, the machine will follow the actual vector shape contained in that font file, which is that outline.

![Outline Font Example](image)

Below is a sample of text written in a common handwriting-like font: The upper line of the sample shows the text filled in, as it will typically appear on your screen, or when printed on a laser printer. The lower line shows the outline: _These are the actual vector shapes contained within the font file, and illustrates how the output will look when printed with a pen plotter._

Now, if you had picked that handwriting-like font with the intent of creating handwriting-like output on the AxiDraw, this is _probably not what you had intended._

The cause of this “unexpected” behavior is that one might easily (though mistakenly) assume that a handwriting-like font contains handwriting-like strokes. The letters “t” and “x” both look like they _could_ be made up of two strokes that overlap, and the “O” looks like it could be a single loop. However, in order for outline fonts to render correctly on your screen, the “t” and “x” are instead each composed of a single (but complex) closed loop, while the “O” consists of two closed loops, one inside the other.

To be quite explicit: there is absolutely no data contained within an outline font that represents or corresponds to the visually apparent centerline of the characters. This fact is consistent for all standard computer fonts, and will present no unexpected behavior, _so long as you are aware of it._
11.5.1 Handwriting-like output with outline fonts

When trying to achieve output close to that of natural handwriting, an “outlined” effect is generally not desirable. To mitigate it, pick handwriting-like fonts that have a thin and consistent stroke width. If a font is available in multiple weights, you’ll want to pick the lightest (thinnest) one available. This, combined with the use of a medium or broad nib pen can often make it so that the two sides of the outline blend together.

Using a broad-point pen, particularly a broad-nibbed fountain pen, is the one of the most effective ways to make a document look closer to hand written. It is also helpful to pick a larger font size, closer to that of natural handwriting (perhaps 18 pt) as a starting point. When writing by hand, people tend to write much larger than typical typed lettering.

If you would like to create a custom handwriting font based on your own handwriting, there are free services online (such as http://calligraphr.com) that can build fonts based on samples that you provide. Even so, note (1) that these are standard (outline) fonts, and the advice above still applies. In most cases (2), fonts automatically generated from your handwriting tend to be very crude as compared to high-quality hand-crafted fonts.

11.5.2 Block and display output

In some cases you may wish to work with text that has large block letters, display text, or other instances with characters that have a wide cross section. Text like this will have a very visible outline, which you’ll usually want to fill in with ink.

The best way to do this is to use the Hatch Fill method, as described in §11.11 Filling shapes and text, on page 72. When you apply a hatch fill, it will create a back-and-forth pattern for the pen to follow, to fill in the shape. While it may be counterintuitive to fill in text this way, it is much closer to how outline fonts are intended to be used: The outline is filled in with ink.
11.6 Stroke fonts

In addition to regular computer fonts (outline fonts), pen plotters like the Axi-Draw can in some cases make use of a second class of specialized fonts, called stroke fonts, or engraving fonts. In stroke fonts, each visible character is defined by strokes of non-zero width, as opposed to the area within an outline.

While they do have some restrictions, stroke fonts are ideal for use with pen plotters, since they plot efficiently (for example, the “o” is one loop, not two). They are particularly suited for handwriting-like applications, because they can closely mimic how humans write: Along the center lines of the text.

The following sample of text is rendered with a stroke font, using a special application called Hershey Text. The second line is identical to the first, except that we have colored the individual paths (strokes) within each character so that you can tell them apart:

Stroke Text Example
Stroke Text Example

As you can see, characters like the “t” and “x” here are composed of two intersecting strokes. Similarly, a letter “o” in this font consists of a single loop. This particular stroke font is a single-stroke font, since each visible line is made up of only a single path. Some other stroke fonts instead use multiple strokes to construct wider characters, e.g., bold fonts.

There two important drawbacks to stroke fonts. First, they are not regular computer fonts, so they generally cannot be used in the same ways as other fonts. You cannot, for example, install them as regular fonts on your computer nor use them in word processors or graphics applications. Second (and mostly because of that first reason) there are at present few available stroke fonts. Despite these obstacles, stroke fonts are still worth mentioning: In cases where you can use them, they are the best solution for using fonts with a plotter.
11.7 Hershey Text

Inkscape includes a special application that we developed called **Hershey Text**, which is capable of typesetting text in a small number of included stroke-based fonts.

When you use Hershey Text, it takes editable text (that is, text that you type) and replaces it with rendered stroke-font text: a set of vector paths that the pen can follow. Once you have rendered text into paths, it can no longer be edited as though it were text. (The paths can be edited with Inkscape’s path editing tools.)

You can find Hershey Text in the menu at **Extensions > AxiDraw Utilities > Hershey Text**.

To use Hershey Text, start with a document that contains text objects. Select the **Render** tab, and choose a font face from the pop-up menu. When you click **Apply**, it will render all text elements on your page into the selected stroke-based typeface. If you would like to convert only certain text elements, click Apply with just those elements selected.

If the **Preserve original text** box is checked, then the original text elements on the page will be preserved even when you click **Apply**. If it is unchecked, then the original font elements will be removed once rendered.
In addition to rendering text, you can use the **Utilities** tab of Hershey Text to generate a table of the single-stroke font faces that are available to use.

A full user guide for Hershey Text is available at: [https://wiki.evilmadscientist.com/hershey](https://wiki.evilmadscientist.com/hershey)

### 11.8 Hershey Advanced and AxiDraw Merge

Two commercial software tools are available at no added cost to AxiDraw owners. To request a download link, please contact us directly: [https://shop.evilmadscientist.com/contact](https://shop.evilmadscientist.com/contact)

#### 11.8.1 Hershey Advanced

**Hershey Advanced** is a more capable version of Hershey Text.

Like Hershey Text, Hershey Advanced performs font substitution in your document, replacing text composed of regular computer fonts with plotter-ready stroke-based lettering. It also offers the ability to introduce subtle “handwriting-like” defects, to help break the appearance of computer-generated writing.

#### 11.8.2 AxiDraw Merge

**AxiDraw Merge** is software designed to automate certain workflows on the AxiDraw, and encompasses the primary capabilities of both AxiDraw Control and Hershey Advanced.

AxiDraw Merge can in a single step perform stroke-font substitution on your document using Hershey Advanced (complete with handwriting-like defects) and plot it on the AxiDraw.

You can also use AxiDraw Merge to automatically populate a template with data sourced from a CSV (spreadsheet) file, perform font substitution using Hershey Advanced, plot the document, and repeat with data from specified rows of your CSV file.
11.9 Capturing signatures and handwriting

The best way to transform some handwritten text — whether a signature or a full page of text — into something that the AxiDraw can plot is to use direct handwriting capture, or what you might refer to as “real-time” capture.

In direct capture, you use your computer to record each stroke as it is written, and then save the resulting set of paths as a vector artwork file. This method can also be used when replicating handwriting. For example when replicating historical signatures, it is necessary to trace along the strokes of existing writing and to capture those strokes as you trace them.

For much more about ways to capture and trace handwriting — including a link to jSignature, a program that can easily capture your signature in real time — please see our detailed documentation on the subject:

http://wiki.evilmadscientist.com/capture

A link to this page can also be found on our main documentation site,

http://axidraw.com/docs

11.10 Aside: Tracing of scanned handwriting

While we are frequently asked about this, it should be noted that there is not any straightforward way of automatically converting scanned handwriting into a set of high-quality vector paths that a plotter such as the AxiDraw can follow. Simple approaches such as centerline tracing rarely approximate the quality and character of real human handwriting.

This is a longstanding problem in artificial intelligence called “handwriting trajectory reconstruction.” Solving it is well outside of what the AxiDraw software aims to support. (Again, the function of the AxiDraw is to plot the vectors that you supply to it.)

When software that performs handwriting trajectory reconstruction comes to exist some day, the AxiDraw will be here, ready to plot its output.
11.11 Filling shapes and text
The AxiDraw follows the actual vector paths in your documents, and thus normally ignores any “fill” inside shapes, since fills do not consist of vector paths.

A special utility is included with the AxiDraw software that can fill shapes with vector paths – hatch marks – such that the shapes can be filled in with pen strokes on your page. You can find it in the menu at Extensions > AxiDraw Utilities > Hatch fill.

Hatch Fill will fill any selected objects with a series of back and forth lines, with adjustable spacing and angle. The hatch spacing is measure in units of screen pixels (px), and the default value of 5.0 is appropriate for wide permanent markers. A lower spacing will produce a more uniform fill, and a higher spacing will produce a more traditional hatch fill for shading. You can use the “Live preview” option to see the effects of different choices without actually applying them to your shapes and text.

The “Connect nearby ends” option, enabled by default, connects the ends of the hatch lines to make long wiggling paths that plot very efficiently. An additional option is provided for insetting the fill from the edges. This helps to avoid “coloring outside the lines” when using the hatch fill.
Here are some examples of how different settings can be used in Hatch Fill. Each of the following are examples are shown actual size, with a 0.016 inch (0.4 mm) stroke width, similar to that of a fine rollerball pen. The Tolerance parameter was set to 1.0.

<table>
<thead>
<tr>
<th>Objects, including any applied hatches</th>
<th>The hatch fill alone</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td>(1) No fill</td>
</tr>
<tr>
<td><img src="image2.png" alt="Image" /></td>
<td>(2): Spacing 3 px, Angle 0°. Connect nearby ends: off Inset: off</td>
</tr>
<tr>
<td><img src="image3.png" alt="Image" /></td>
<td>(3) Spacing 3 px, Angle 45°. Connect nearby ends: off Inset: on, distance 1.0</td>
</tr>
<tr>
<td><img src="image4.png" alt="Image" /></td>
<td>(4) Spacing 3 px, Angle 45°. Connect ends: On, Range 3. Inset: on, distance 1.0</td>
</tr>
<tr>
<td><img src="image5.png" alt="Image" /></td>
<td>(5) Same as (4), but with crosshatch: on</td>
</tr>
<tr>
<td><img src="image6.png" alt="Image" /></td>
<td>(6) Same as (4) but with Spacing 1.0 px (crosshatch is off)</td>
</tr>
</tbody>
</table>

Examples (4) and (6) above — with a single hatch at 45 degrees, inset from the edges, and with the ends connected — usually give good results for most situations. The key parameter that you’ll need to adjust (based on the pen that you use and so forth) is the Hatch Spacing.
Vectorizing images

The process of turning images (JPG, PNG, photoshop files, etc) into vector artwork is generally outside the scope of the AxiDraw software. That said, how to do so is a frequently asked question so we are including some notes on the subject.

The process of converting a photograph into a piece of pen-ready vector line art can most accurately be described by the word “sketching.” That is to say, it is not so much a matter of file conversion as one of artistic interpretation. There are genuinely a limitless number of ways to represent a photo with a set of strokes. Artists that work with plotters often write their own programs to perform this kind of conversion, and we will point out a few of these programs.

Inkscape includes a vectorizing tool, found in the menu at Path > Trace bitmap. It works by tracing the outlines of darker regions. It does work, and is sometimes useful for very simple shapes, but it generally does not produce high quality output that works well on plotters. You may end up with (for example) ghostly effects, or tens of thousands of tiny little loops that represent stray pixels on the input photo.

While this is nowhere near a comprehensive list, here are three examples of output from different vector “sketching” programs. All three of these are free programs that are written and run in the Processing development environment.

This portrait was generated from an image with SquiggleDraw, available at: https://github.com/gwygonik/SquiggleDraw
The portrait above on the left is a stipple drawing, made with thousands of tiny circles of different sizes, as generated by StippleGen:

http://wiki.evilmadscientist.com/stipplegen

The portrait above on the right consists of a single wandering line. Plots like this can potentially print quickly because there is no pen up/pen down movement. This one was generated with an experimental program called ScribbleDraw, available upon request: https://shop.evilmadscientist.com/contact
12. Maintenance and troubleshooting

AxiDraw V3 family plotters should not require any regular maintenance under normal conditions.

12.1 Troubleshooting plot area
If you should find that the AxiDraw does not appear to have access to the full plotting area of the machine, double check that you have selected the correct model of AxiDraw in §9.9 The Config tab, on page 55.

12.2 No lubrication required
The X carriage contains wheels that allow the X shafts and Y parts to slide. The wheels contain shielded and/or sealed ball bearing mechanisms that are permanently filled with grease. The pen-lift (Z) stage uses grease-free Teflon-filled plain bearings. *Do not apply oil or grease to any of the sliding mechanisms.*

12.3 Cleaning
Clean the AxiDraw only with a soft, clean cloth. The non-electronic metal parts may be cleaned with a cloth moistened with soap and water if needed. Avoid other cleaners and solvents. Do not wet the motors, cables, or controller board.

12.4 Storage
It is recommended to store the AxiDraw with the carriage either in the Home position or (especially if it needs to be put away in a box) in the far opposite corner, fully extended in X and Y, such that the cable guides are fully extended and have the lowest profile. Unplugging the AxiDraw’s plug-in power supply when not in use will prolong the life of the machine.

12.5 Belt tension
The AxiDraw uses a single timing belt, looped in an “X” around the two motors and the Y carriage. This belt may gradually stretch a small amount, and can be re-tensioned where it is anchored, if necessary. The necessary hex wrench (2.5 mm) is included with the AxiDraw. Do not retension the belt unless it is actually necessary to do so.

12.6 The wrenches
Several hex wrenches and two thin-profile crescent are included with the AxiDraw. One of these – the ball-end 5/64” (2 mm) wrench – is used for switching the pen between the vertical and angled orientations. The others are provided in case more significant adjustments are required; they are not needed in most circumstances. However, if something should come loose, it is nice to have the right tools on hand. Contact technical support for guidance if needed.
12.7 Wiring
If your motor wires should become disconnected at some point, the correct wire order is as follows: Left motor: “Motor 2” locations, yellow, red, green, gray (from top to bottom). Right motor: Motor 1 (same order). Servo cable: B1 (lowest three pins on left hand side), with black wire towards the edge of the board. Refer also to the illustrations in section “2.3 Unboxing AxiDraw” on page 12.

12.8 The pen-lift servo motor
The only expendable component of the AxiDraw is the small, blue pen-lift servo motor. They do wear out over time but are inexpensive and straightforward to replace. For applications where you cannot afford any down time, we recommend that you keep a spare on hand. Spares are available at https://emsl.us/903 and through select resellers.

If you are setting up an AxiDraw for the first time and the pen-lift motor does not appear to be operating, double-check that you have connected the cable correctly, following along with §2.3 Unboxing AxiDraw, on page 12.

12.9 Loss of position
The most significant thing that can go wrong under normal operation is a loss of position control while the carriage is moving. This is typically manifested as a loud grinding or screeching noise. It can happen when moving at too high of a speed, or when the carriage hits an unexpected obstacle– for example if it was not moved to the Home Corner before plotting or if it was bumped while moving.

If this should happen, press the pause button as soon as possible to cancel the plot. Remove power to the machine if necessary. Use Disable XY Motors or Raise pen, turn off motors in the setup tab to de-energize the motors, and then manually return the carriage to the Home Corner before trying to plot again. As a sanity check, the carriage should return exactly to the Home Corner when a plot is finished.

12.10 Service, repair, and parts support
The AxiDraw is designed to be serviceable, and we are here to help. Nothing should require regular replacement. However, most parts of the machine can be unscrewed and replaced if necessary. Please contact technical support directly if you need assistance with troubleshooting or repairing a mechanical issue.
13. AxiDraw Tips and Tricks

1. It is often possible to get better print quality on top of a small stack of paper (say, 5-10 sheets) which gives a little cushion to your writing.

2. High quality paper – especially paper designed for use with pens – tends to give dramatically better results with pens than does cheap copy/laser paper. Bristol paper with a smooth finish is a great example of a paper designed to work well with pens.

3. The flatter that your paper is held, the better your print quality will be. Paper that is warped or “bubbled” will flex as the pen writes, leading to distortion. When the bubbles or warping are tall enough, it can also lead to stray marks on your page during pen-up movements.

4. Reducing the amount of vertical pen travel that is needed will make your plots faster, and also improve print quality, since the pen-lift servo motor does introduce vibration.

5. If none of the motors move but (1) everything looks correct, and (2) your computer doesn’t report any errors, triple check that the 9 V power supply is plugged into a working outlet.

6. When making multiple-color plots, you can get better registration when switching pens by making sure that each pen is set to the same height above the paper. A good way to do this is to rest the tip of the pen on a spacer when tightening the pen in place. Use a small, flat piece of wood, plastic, or metal.

7. It is possible to completely detach the AxiDraw’s pen holder, and affix other types of tools to the front of the Y carriage. Four M4 tapped (or tappable) holes are provided for mounting other types of tool heads there.

8. Certain types of pens can “dry up” if left in the pen-up position for a minute or two. This can lead to an awkward situation where ink does not start flowing until after the machine has already been drawing for a bit. When working with pens like this, it may be helpful to “bleed” out the tip with a bit of scratch paper before printing.

9. Styles applied to paths (width, color, etc) are normally ignored by the AxiDraw software. If you have a dashed line and want it to plot with the dashes visible, you can use Extensions > Modify Path > Convert to Dashes to convert the dashes into separate path segments.

10. One of the simplest things that you can do to improve the quality of your output is to use a medium or broad-nibbed fountain pen. (Lamy Safari is an excellent starter choice.)
11. A single rubber band can be looped loosely around the pen holder as shown, to add a small amount of additional pressure for use with ball-point pens, or for operating the AxiDraw in other orientations (where gravity is not readily available to pull the pen to the surface). Do not add a rubber band unless it is actually needed; the extra load will shorten the life of the pen-lift servo motor. Example rubber bands are included with the AxiDraw, but will degrade over time.

12. Inkscape has a keyboard shortcut, Alt-Q (Option-Q on Macs), which will execute the last Inkscape extension once again. This is frequently useful when repeating a command, such as making one additional copy of a plot, without having to open the AxiDraw Control panel again.

13. You can also add your own keyboard shortcuts within Inkscape – for example, maybe you want a shortcut for running the Disable XY Motors extension, or to open the AxiDraw Control panel. To begin, open up Edit>Preferences (Windows, Linux) or Inkscape>Preferences (Mac), and select Interface>Keyboard Shortcuts from the left-hand column.

14. When saving graphics in SVG format from Adobe Illustrator or CorelDRAW, a helpful tip is to select the “Presentation attributes” option in the SVG export options. This typically helps to make the formatting work better in Inkscape.

15. The order in which objects on your page will plot is generally determined by the order in which they were initially drawn. “Lower” objects on the same layer will print before “higher” objects on the same layer. You can use the Object > Raise and Object > Lower commands to re-order objects. For more about plot order, see §9.7 Plot order and optimization, on page 49.

16. A range of AxiDraw accessories are available, including larger-size pen holders, extra easel boards, magnetic easels, mounting hardware and more. For details, please see https://emsl.us/902
Extended online documentation & resources for AxiDraw:

axidraw.com/docs

---

Evil Mad Scientist

Blog:  www.evilmadscientist.com
Store:  shop.evilmadscientist.com
Docs:  wiki.evilmadscientist.com
Chat:  https://discord.gg/axhTzmr
Humans:  shop.evilmadscientist.com/contact