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Preliminaries

0.1 Quick Start?

If you’re new to AxiDraw, and want to get up and running as quickly as possible,
here are the most important parts to know about:

1. Follow section “2.3 Unboxing AxiDraw”, starting on page 14.
This section covers a couple of initial hardware setup steps
that you don’t want to miss.

2. Install software.
Visit axidraw.com/sw for the latest downloads and instructions

3. Section “4. Quick start: Making your first plot”, starting on page 20.
Follow along with this section, which walks you through the
steps of making your first plot with the AxiDraw.

4. Contacts & resources: Here, and again on the last page of the guide.
If you get stuck or need advice at any point,

please don’t hesitate to reach out for help!

Contact us: shop.evilmadscientist.com/contact

Our live support chat:  axidraw.com/chat

Online documentation and resources: axidraw.com/docs



https://axidraw.com/sw
http://shop.evilmadscientist.com/contact
http://axidraw.com/chat
http://axidraw.com/docs

0.2 Welcome to AxiDraw!

This is the user guide for the AxiDraw V3 family of high-performance personal
writing and drawing machines. This guide is here to help you get started. There
is a lot here — covering how you set up and use the machine, tips for operation,
details about the software, and pointers to additional resources.

This guide covers operation of the following standard AxiDraw models:
- AxiDraw V3,V3/B6, and V3/A3
- AxiDraw SE/A3 and SE/A4
- AxiDraw V3 XLX

Additionally, sections 3-13 of this guide, covering everything except the physical
setup of the machine, are applicable to the AxiDraw MiniKit and large-format
machines AxiDraw SE/A2 and AxiDraw SE/A1.

0.3 This guide is updated from time to time.

Both this guide, and the AxiDraw software are updated from time to time. We
encourage you to check back occasionally for the latest version of this manual,
and to check that you have the latest version of the software. You can also use
the Config tab of AxiDraw Control to check online to see if you have the latest
version.

Recent changes to this guide include updates for the current software version,
which is v3.9.0 as of the time of writing and for Inkscape version 1.2. Recently
added features include the option for hidden-line removal, and support for the
new narrow-band brushless servo option.

You can download the latest version of this guide at http:/axidraw.com/guide

Look at the front cover of the guide to find the date and version number of the
guide that you are looking at.

0.4 Copyright notice

Software and manual: © 2023 Windell H. Oskay, Evil Mad Science LLC


http://axidraw.com/guide
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1. Introducing the AxiDraw

The AxiDraw is a simple, modern, and precise pen plotter, capable of writing or
drawing on almost any flat surface. It can write with your favorite fountain pens,
permanent markers, and other writing implements to handle an endless variety
of applications. Its unique design features a writing head that extends beyond the
machine, making it possible to draw on objects bigger than the machine itself.

The AxiDraw is an extremely versatile machine, designed to serve a wide variety
of everyday and specialized drawing and writing needs. You can use it for almost
any task that might normally be carried out with a hand-held pen.

It allows you to use your computer to produce writing that appears to be hand-
made, complete with the unmistakable appearance of using a real pen (as op-
posed to an inkjet or laser printer) to address an envelope or sign one’s name.
And it does so with precision approaching that of a skilled artist, and — just as
importantly — using an arm that never gets tired.

1.1 Credits and History

The AxiDraw project has been active since 2014, when it was first created by Dr.
Lindsay Robert Wilson of |J Instruments Ltd. in the UK.

AxiDraw, 2014

Early AxiDraw units had a different design. It had a smaller format with a chassis
made from machined Delrin plastic. It had two independent timing belts, one
driven by a stepper motor on the base, and the other by a stepper motor on the
moving carriage. For software, it used a modified version of the WaterColorBot
driver developed at Evil Mad Scientist.



AxiDraw V2

In 2015, Wilson began collaborating with Windell Oskay and Lenore Edman of Evil
Mad Scientist Laboratories towards a new AxiDraw model that would be designed
and manufactured in the USA.

AxiDraw V2, 2016

This second-generation AxiDraw was enlarged to reach twice the travel area, to
cover a full page of A4 or US Letter paper. Its geometry was changed to use a
single drive belt, with two larger stepper motors stationary on the base. Its major
components would now be made of aluminum (machined or stamped and folded),
and the new pen holder could be mounted vertically or at 45° to the paper.

AxiDraw V3

The third generation, the AxiDraw V3 family, is a full redesign of the machine for
higher performance.

AxiDraw V3

While previous models had steel shafts and linear ball bearing slides, this new
version features custom aluminum extrusions with rolling wheels. The vastly in-
creased stiffness of the structures — without added weight — allow the machine
to operate at significantly higher speeds and with higher precision than older ge-
ometries based around steel shafts.

The AxiDraw V3 family is currently available in several models that differ principal-
ly in available travel area: AxiDraw V3, AxiDraw V3 XLX, and the AxiDraw V3/A3.
There is also a Special Edition, AxiDraw SE/A3, which features a base machined
from a solid block of aluminum.
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2. Checking out your AxiDraw

1. AxiDraw

USB Cable

Hex drivers and wrenches

2.1 Parts and accessories

Here are the parts that come with AxiDraw:

1. The AxiDraw itself

2. Clip Easel and binder clips (4 on AxiDraw V3, 8 on larger models)

3. Plug-in power supply

4. USB cable

5. Hex drivers and wrenches
Sizes include 2 mm, 2.5 mm, and 3 mm hex drivers, and low-profile 8 mm
and 10 mm wrenches. Of these, only the smallest (2 mm) hex driver is
used in regular operation. The rest are normally not needed.

6. Rubber bands
These can be used to add a little extra pen-down force if needed.
See the last chapter, AxiDraw Tips and Tricks.

7. Not shown: Extra rubber feet (AxiDraw V3 and V3 XLX only)
Normally not needed. But, just in case a rubber foot gets bumped off of
the base during shipping, spares are included.

8. Not shown: Special accessories included with AxiDraw SE/A3
The SE/A3 also includes an XL pen clip and an italic pen adapter.
These are available separately for use with other AxiDraw models.

To learn more about available AxiDraw accessories, please visit: emsl.us/902

1



2.2 AxiDraw anatomy

Let us look at the different parts of the AxiDraw. We will refer to these parts by
name throughout this guide. These features are common to each model of Axi-
Draw, though appearances may vary. For example, the AxiDraw V3/A3 and SE/
A3 have extended “outrigger” feet, and the AxiDraw SE/A3 and SE/A4 bases are
colored black and covers the two motors.

Carriage (X-axis part) Right motor

Cable Guides
& cover

(Not handles!)

Pen holder

Left motor & cover

ey Top View
@ Carriage (Y-axis part)

Timing (drive) belt

\

'Y

Base; Central strut

Pen holder
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Detail: Left side of base

Power Jack
Home Position Label

EBB
Cover

f

Cable for
pen-lift motor

~<—— Rubber

Feet
USB Port

Stepper motor
Pause Button “EBB” Control board

Y Carriage

/

Detail: Pen holder

/Vertical slide

Pen Clip
Screws

Pen-lift
servo motor

“/ Thumbscrew

Vertical shafts )
Pen Clip

Note: AxiDraw ships with its pen clip disconnected; see the next section.
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2.3 Unboxing AxiDraw

The cable for the pen-lift motor and the pen clip are disconnected for shipping.
Your first two steps, out of the box, are to re-attach these parts.

Locate the disconnected cable end
on the left hand side of the base.

The cable has three wires: Black, red, and white.

Plug its connector into the bottom three pins on the EBB Control Board
as shown. The black wire faces back, towards the edge of the board.

14



The pen clip is also
removed for shipping.

2 mm ball-end
hex wrench

'S

M3 Screws

Thread the black plastic thumbscrew into the pen clip.

Attach the pen clip to the vertical slide with the two small black M3 screws, using
the 2 mm hex wrench, which has a ball end for easier access. The pen clip may be
attached eitherin a vertical or diagonal orientation, depending on what kind of a

writing implement you are using.
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The pen clip can be attached in two different positions: Vertical, which positions
the pen straight down, or diagonally, which holds the pen at a 45° angle to the

paper.

Aside: If you have an older AxiDraw...

AxiDraw V2 and first-generation AxiDraw V3 units have four threaded holes on
the vertical slide and two holes in the pen clip (rather than two threaded holes
and four holes on the pen clip). If you have one of these machines, it looks a little
different, but you still use the two screws to attach the pen clip in the vertical
or diagonal position.

Current-generation AxiDraw accessories (http:/emsl.us/902), such as the italic
pen adapter, and pen clips are compatible only with the 2-hole slide. If you have
one of these older machines and would like to use current-generation accesso-
ries, please contact technical support about an adapter plate.
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2.4 Safe handling of the AxiDraw

1. Lifting: Lift AxiDraw by the central strut of the base, or by the stepper motors
if necessary. Do not lift by the cables, cable guides, carriages, or pen holder. The
AxiDraw SE/A3 has a handle milled into the back of the central strut, to provide
an additional lifting point in the middle of the machine.

2). Heat: Please note that the two stepper motors may get warm. This is normal,
but it is helpful to be aware of it. They should not get too hot to touch.

3). Moving parts: AxiDraw has exposed moving parts. Keep fingers, hair, and oth-
er things that could get caught, crushed, or tangled safely away from the belt and
the pinch points between the moving carriage, the pen holder, and the motor
covers.

Warning: Keep fingers away from pinch
points while AxiDraw is operating.

17



3. Software for AxiDraw

3.1 Installing software

You will need to install software on your computer to operate the AxiDraw.
Current instructions and download links are available at: http:/axidraw.com/sw

From there, follow the directions specific for your operating system:
- For Mac and Windows, there are easy installers that you can download.
- For Linux, one or more manual steps are required.

The software that you will install includes Inkscape, the superb (and free) drawing
program, and a set of extensions that operate the AxiDraw from within Inkscape.

If you run into any difficulty while following along with the installation steps,
please contact us for technical support —we are here to help. You can find our
contact information on the last page of this user guide.

3.2 Inkscape and the extensions

Once you have installed the software, launch Inkscape. The AxiDraw software is
located within the Extensions menu of Inkscape.

 criensons LD

| Previous Extension XQ |
Previous Extension Settings... X{Q

Arrange »
AxiDraw Control...

AxiDraw Utilities >
~nlar » 1

There are two relevant items in the Extensions menu: AxiDraw Control, the pri-
mary software interface to AxiDraw, and the AxiDraw Utilities submenu, which
contains several supplemental tools.

J

AxiDraw Control... | v-|gR 425 w130 R17
AxiDraw Utilities > AxiDraw Naming...

A Color > Disable XY Motors I
Document > Hatch fill...
EggBot > Hershey Text...
Export > Plot Optimization (Legacy)...
Gcodetools > Process lllustrator SVG...
Generate from Path >

Later in this user guide, we will go into depth about the different features of the
software and how to use it.
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3.3 Aside: Alternative software, CLI, and APlIs

The AxiDraw software is available in two alternate versions that may be helpful
for developers or for anyone who would to control the machine programatically
rather than through Inkscape. There is a stand-alone command-line interface
(CLD tool, as well as a full-featured python library. Both of them are fully supp
and have essentially the full set of features otherwise available through Inkscape.

You can learn more about these tools at:

https://axidraw.com/doc/cli_api and https://axidraw.com/doc/py_api

If you would like to directly interface to the AxiDraw’s EBB motor control board,
it has a fully documented serial command protocol that you can control from
any programming interface that can address your USB port.

RoboPaint is an alternative software package available for painting and drawing
robots. It requires a separate install process, and is not as well supported as the
official tools, but it does work with AxiDraw. It also has a built-in REST API. There
are also various other third-party software tools that can control the AxiDraw.

For more information about these alternatives, please see the documentation
and links on our wiki site: http:/axidraw.com/docs

19
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4. Quick start: Making your first plot

In this section, we will briefly walk through the steps to make your first plot. After this
section, we will discuss each part of this process in additional depth.

As you get started, please make sure that you have gone through §2.3 Unboxing
AxiDraw, on page 14 (so that you have connected the cable and installed the
pen clip) and §3.1 Installing software, on page 18.

4.1 Pen, paper, and the clip easel

For your first plot, you'll need a pen (or something else to write with) and paper
(or something else to write on).

The easiest way to get started is to use the Clip Easel, a hardboard with binder
clips, included with the AxiDraw. Clip a piece of paper to the top of it.

} =

<

For more information about the Clip Ea-
sel and other methods of workholding,
see §6. In detail: Workholding, on page
27.

4.2 Move to the Home corner

Prior to plotting, it is necessary to move the AxiDraw carriage to the Home Cor-
ner. This is where the carriage is as far left and as far back as it can go: where the
pen holder is closest to the engraved label “Home”.

Home
Position
Label

20



Once you have identified the Home Corner, slide the carriage there by hand.

You can move the carriage by the solid block of
metal behind the vertical slide of the pen hold-
er. (Do not push the vertical slide itself or the
pen clip directly.)

If the carriage does not move easily, you may

need to turn off the motors. To do so, select

from the Extensions menu in Inkscape:
AxiDraw Utilities > Disable XY Motors

For more about the Home corner, please see
§5. In detail: The Home Corner, on page 26.

4.3 Connect Power and USB

Next, connect the power and USB cables to the AxiDraw as shown below. Con-
nect the USB cable to any available USB port on your computer, and plug the
power adapter into a working outlet.

Power Adapter Cable

USB Cable

For more information about the power and USB cables, please see
§7. In detail: Power and USB, on page 30.
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4.4 Check pen-up and pen-down positions

Within Inkscape, open AxiDraw Control from the top menu. You can find it at
Extensions > AxiDraw Control. Then, select the Setup tab:

® @ AxiDraw Control
Plot Setup Options Manual Layers Resume
—
Basic Setup
Pen height: UP (%): 60 —-

Pen height: DOV YCAY 30 —4

Action on "Apply": @) Cycle pen down then up
Raise pen, turn off motors
Toggle pen between up, down

- Cycle pen down then up to check the vertical positions of the pen.

- Raise pen and turn off stepper motors to manually move carriage to the Home
Corner (back left).

Preview mode (Simulate plotting only)

Close Apply

Select the Cycle pen down then up option, and click the Apply button.
If everything is hooked up correctly, the pen lift motor should lower to its pen-
down position, wait just a moment, and then lift to the pen-up position. It will do

so again each time that you press Apply.

Pen up

Pen down

If there is no movement, double check that you have power and USB connected
as given in the previous section. If it still does not move, also check that you have
correctly hooked up the cable in §2.3 Unboxing AxiDraw, on page 14.
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4.5 Insert your pen

Starting with the AxiDraw in the pen-up position, insert your pen into the pen
clip, just above the paper, and tighten it in
place with the thumbscrew.

The vertical position of your pen should be
approximately 1/8 to 1/4 inch (3 - 6 mm)
above the surface of the paper.

Take care to only apply gentle force with
the thumbscrew; do not tighten it more
than necessary.

For more about pens and pen choices, see
§8. In detail: Setting up pen and paper, on
page 31.

Pen up gap:
1/8 - 1/4 inch
(3-6 mm)

above paper |

4.6 Position your paper

With the carriage still at the home corner, position the upper-left corner of your
paper directly beneath the tip of your pen, such that if your pen were to be low-
ered, it would touch the corner of the paper closest to the Home corner.

The photo above shows the paper positioned correctly, with its corner directly
under the tip of a pen - in this case a fountain pen mounted at 45° to the paper.

For additional examples of paper positioning, please see §8.5 Positioning paper, on
page 36.
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4.7 Open a document and print it

Download the set of AxiDraw example files from http://axidraw.com/ex

The download is a small zip archive of example files. Open (unzip) the archive.
Then, within Inkscape, open up the file called AxiDraw_First.svg. Once open, the
document should look approximately like this:
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If you cannot see the full page outline when you first open the file, select from
the menu View > Zoom > Page, or type the number ‘5’ on your keyboard.

Finally, open AxiDraw Control, switch to the Plot (first) tab of AxiDraw Control,
and click Apply to begin the plot.

[ ] [ ] AxiDraw Control

Plot Setup Options Manual Layers Resume

AxiDraw Control
Press "Apply" to begin plotting. Use other tabs to adjust
settings and access additional AxiDraw functions.

AxiDraw documentation is online at: axidraw.com/docs . For technical
support, email contact@evilmadscientist.com or visit axidraw.com/chat

Copies: CopiestoPlot: |1 —-
Page Delay (s): 15 —-

Tip: Select 0 copies to plot continuously.

Version 3.9.0 — Copyright 2023 Evil Mad Science LLC

Preview mode (Simulate plotting only)

Close Apply
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The AxiDraw should now begin printing your document, and will return back to
the Home Corner, with pen up, when it finishes. With a black pen, it will look
something like the following:
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If you need to stop the plot for any reason, press the Pause button on the left
side of the machine. (See “2.2 AxiDraw anatomy” on page 12.)

4.8 Recap: Setting up a print

Let us summarize the steps that we've been over:

1) Move the AxiDraw to its Home Corner.
2) Plug in power and USB.
3) Using the software, cycle the pen down and back up.
- From the menu, select Extensions > AxiDraw > AxiDraw Control
- In the Setup tab, use the Cycle pen down then up option.
4) Clip in your pen, with height just above the paper.
5) Position your paper with its upper-left corner below the pen tip.
6) Using the Plot tab in AxiDraw Control, click Apply to plot the document.

The next few sections of this guide, §5-8, cover these same topics in greater detail.

4.9 Setting the machine size

One final tip as you get started: By default, the travel limits set in the software
are those for the AxiDraw V3. If you are using an AxiDraw of different size, such
as the AxiDraw V3/A3 or AxiDraw SE/A3, be sure to select your AxiDraw model
in the Options > Config tab of AxiDraw Control.

For more information, see §9.11 The Config tab, on page 63.
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5. In detail: The Home Corner

Before you start plotting, the carriage must be moved to the Home Corner. This
is as far left and as far back as it will go: where the pen holder is closest to the
left side of the base, that is when the pen holder is closest to the engraved label
“Home”, and the USB port.

Home
Corner

Home Position
Label

ANNA IS HAVIN
A BIRTHDAY PARTY...
AND YOU'RE INVITED!

Mareh 19, 6:00 PM @Anna's
(1337 Spring Lane) RIVP!

When a plot finishes, the AxiDraw will return to its Home Corner automatically,
leaving it ready for your next plot.

Slide the carriage to the Home Corner by
hand. You can move it diagonally by holding
the solid block of metal behind the vertical
slide of the pen holder. Do not push the ver-
tical slide of the pen holder directly.

The carriage should only be moved when
the power to the motors is off. If it does not
move easily, turn off the motors so that you
are not trying to force them.

To turn off the motors, select Extensions > AxiDraw Utilities > Disable XY Motors
from the menu in Inkscape. Alternately, you can use the “Raise pen, turn off mo-
tors” command in the Setup tab of AxiDraw Control (see page 33) or physi-
cally disconnect the AxiDraw from power.
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6. In detail: Workholding

Whatever workpiece the AxiDraw is to write or draw upon - whether that is pa-
per, boxes, wood, cloth, or cookies - needs to be held in place so that it does not

shift while plotting.

B e e et

6.1 Printing on large workpieces

For large items such as a box or the post-
er board shown here, the AxiDraw may be
placed directly on top of the workpiece.
Other examples of large workpieces that
AxiDraw can sit upon might include things
like fabric, wooden surfaces, chalkboards
or whiteboards.

6.2 Workholding with the Clip Easel

A Clip Easel, a simple hardboard with clips, is included with the AxiDraw for hold-
ing smaller workpieces - principally different shapes and sizes of paper - that
are not large enough to be held down by the AxiDraw itself. This is a great way to
mount paper when getting started with the AxiDraw.

The AxiDraw V3 Clip Easel is 9 x 12 inches (about 23 x 30 cm) in size, with rub-
ber feet and small binder clips. (Larger easels are included with the larger-sized
AxiDraw models.) You can mount different sizes of paper to it, including US letter
size (or A4) paper, and smaller sizes including envelopes, cards, and invitations.
With smaller paper, you can also potentially mount several pieces at the same
time. The clips can be positioned as needed to hold the paper flat, and avoid the
areas where you will be writing.
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§6.2, Workholding with the Clip Easel, continued
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The examples shown above are:
A) A certificate to be filled out (Letter size, landscape orientation)
B) Mailing address (#10 envelope, landscape orientation)
C) Aformal invitation (6 % x 8 % inch, portrait orientation)
D) A page of mixed text and drawing (Letter size, portrait orientation)

In every case, line up the corner of the paper with the upper left corner of the
Clip Easel, such that the corner of the paperis closest to the Home Corner.

6.3 Document orientation

If your document is wider than it is tall (or square), it is said to be in landscape
orientation, and your paper should be oriented as in examples A and B above.
If your document is taller than it is wide, it has portrait orientation; and will print
“sideways” as in examples C and D above. (This default behavior can be overrid-
den; See “9.8 Advanced options” on page 55.)

28



6.4 Using multiple Clip Easels

A common technique is to use more than one clip easel, such that you can quickly
swap out your completed workpiece for the next one. The key advantage is that
one page can be plotting while you unclip and clip the next page. You can use
tape marks or hard end stops on your table (like a carpenter’s square) to facilitate
quick alignment.

A second method can be used when your workpieces are substantially smaller
than the working area of your machine. For example, if you are labeling small note
cards with the AxiDraw, or if you are plotting two side-by-side letter (A4) size
pages with the AxiDraw V3/A3 or AxiDraw V3 XLX. Using two small easels side by
side, you can designate one “A” and one “B”, and alternate plotting on the “A” or
“B” side. If you change out each side when it finishes, you can plot continuously
without ever pausing to swap out the paper.

6.5 Moving beyond the Clip Easel

While the Clip Easel is versatile, it is also entirely optional. Paper can be held in
place with tape, clamps, tacks, paper clips, magnets, other types of clipboards,
the weight of the AxiDraw itself, or by other means that you see fit.

If you only use one pen and paper size consistently, you may prefer to make a
workholding solution tailored for your specific application. In some cases, making
a fixture that is permanently mounted to a tabletop or work surface can save you
a great amount of time.

6.6 Magnetic easel accessories

Magnetic easels - steel boards with rulers and magnets - are available as optional
accessories for AxiDraw. Visit https://emsl.us/902 for more information.
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7. In detail: Power and USB

Power Adapter
Cable

USB Cable

The power and USB cables connect to the AxiDraw as shown above.

Connect the USB cable to any available USB port on your computer. All AxiDraw
models currently ship with a USB A to Micro-B cable. You can switch this out for
other types of high-quality USB micro cables (e.g., USB C to Micro-B) as needed.

The plug-in power adapter included with the AxiDraw (9 V dc, regulated, center
positive) works with worldwide mains power (100-240 V ac). Outside of the US,
it may require an inexpensive plug-shape adapter. Do not use an adapter that
changes the voltage.

Once your cables are connected, make sure that the AxiDraw has room to move,
both in front of and behind the machine. Leave room for the Y axis to move, and
take care that as the carriage moves (left to right, back and forward), it cannot
get caught on stray cables.
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8. In detail: Setting up pen and paper

In this section we will discuss different types of pens, configuring the pen angle, the
pen-up and pen-down positions, setting the pen height, and how to set the paper
position relative to the pen.

8.1 Pen choices

The pen holder included with the AxiDraw fits pens up to % inch (16 mm) in diam-
eter. The maximum recommended pen weight is 1.6 0z (45 g). The design is such
that the pen rests on the surface by its own weight. That allows it to ride over
surfaces that are textured or otherwise uneven, however it also means that the
pen holder does not apply much if any downward pressure.

Good choices for pens include fountain pens, permanent markers, rollerball pens,
technical pens, (small-bodied) whiteboard markers, liquid chalk markers, and oth-
er writing and drawing instruments that do not require significant pressure. While
we refer to writing and drawing instruments as “pens” to be concise, otherinstru-
ments such as automatic pencils, chalk, charcoal, and brushes can also work well
in many cases. Others, like traditional ball point pens, may work poorly because
they require a substantial amount of downward pressure to operate.

8.2 Setting the pen angle

The pen may be mounted vertically or diagonally at 45° to the paper by mounting
the Pen Clip in either the vertical or angled position.

v
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To detach the pen clip, loosen and remove the two black M3 screws on the front
of the pen clip, using the 2 mm hex wrench, which has a ball end for easy access.
Use the same two screws to reattach the pen clip, either in the vertical or diag-
onal orientation.
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§8.2, Setting the pen angle, continued

The 45° angle position is ideal for use with fountain pens, but will work well with
most rollerball and fine point markers. The vertical position is more suited to
markers with fatter tips or writing instruments that require more downward pres-
sure. The vertical orientation is also the best choice when making plots that re-
quire you to swap pens - for example when making multicolor plots.

8.3 Inserting a pen

You can insert a pen - or other writing instrument that you are using - into the
pen clip and tighten it in place with the thumbscrew.

Take care to only apply gentle force with the thumbscrew: You need merely to
immobilize the pen; stop tightening it once you encounter moderate resistance.
If the vertical slide does not move freely up and down, the first thing to check is
to make sure that you aren’t holding the pen too tightly.

When using any ink-based pen (whether rollerball, fountain pen, or permanent
maker), it is helpful to “bleed” out the tip before writing. Try it by hand on a piece
of scratch paper, and make sure that ink is actually flowing.

Aside: Fragile or delicate pens: If you choose to use fragile pens (such as high-
end fountain pens with celluloid barrels), exercise great care when inserting
the pen. You may wish to wrap the barrel in a thin, soft cloth to avoid scratch-
ing, and use little or no pressure from the thumbscrew. Moderately priced
fountain pens, like the Lamy Safari or the Pilot Metro shown above, tend to
be quite tough, and require little special treatment.
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8.4 Pen up and pen down positions

In this step we will check the pen-up and pen-down positions.

Within Inkscape, open up AxiDraw Control: Extensions > AxiDraw Control.
Then, select the Setup tab:

@ [ ] AxiDraw Control
Plot Setup Options Manual Layers Resume
Basic Setup
Pen height: UP (%): 60 —-

Pen height: DOV [NCAE 30 —+4

Action on "Apply": - Cycle pen down then up
Raise pen, turn off motors
Toggle pen between up, down

- Cycle pen down then up to check the vertical positions of the pen.

- Raise pen and turn off stepper motors to manually move carriage to the Home
Corner (back left).

Preview mode (Simulate plotting only)

Close Apply

Select the Cycle pen down then up option, and click the Apply button.

If everything is hooked up correctly, the pen lift motor should lower to its pen-
down position, wait just a moment, and then lift to the pen-up position. It will do
so again each time that you press Apply.

Pen down

33



§8.4, Pen up and pen down positions, continued

If there is no movement, double check that you have power and USB connected
as given in the previous section. If it still does not move, also check that you
have correctly hooked up the pen-lift motor cable. (See section “2.3 Unboxing
AxiDraw” on page 14.)

While in the pen-up position, insert your pen and position it above your paper.

—

Pen up gap:
1/8 - 1/4 inch

(3-6 mm)

&—“\_ i A
above paper | ;’ p

The vertical position of your pen should be approximately 1/8 to 1/4 inch (3 - 6
mm) above the surface of the paper. You can physically adjust the position of the
pen with the thumbscrew, and/or change the positions from the Setup tab of
AxiDraw Control.

In some cases it may also be helpful to “toggle” to the pen-down position. To
do so, select the Toggle pen between up, down option and click Apply. Each
time that you press Apply, the pen will alternately go to the pen-down or pen-up
position.

With the pen down, the pen should rest on the paper by its weight. If it does not,
you likely need to lower the pen-down position. (While testing, you can protect
the paper that you will be writing upon with another sheet of paper, to avoid writ-
ing on your actual workpiece.) Even so, it is recommended that you insert the
pen in the pen-up position, rather than in the pen-down position.
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Once you are familiar with the process of inserting the pen and setting the
height, this whole process is described by two quick steps:

1) Cycle the pen holder to the pen-up position.
2) Insert your pen, just above the paper.

The pen-up and pen-down heights in the Setup tab may each be adjusted be-
tween 0 and 100% to suit your needs. Higher percentage values lift the pen high-
er.

The factory-default values of 60% (up) and 30% (down) are a good starting point.
You may also wish to try adjusting them to a different set of values (say, 80% and
50%, respectively) and apply, to see that the positions change when you adjust
them and toggle the pen position.
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8.5 Positioning paper

With your pen at the Home Corner, and the pen at an appropriate height, it is
time to position the paper with respect to the AxiDraw. The printable area starts
at the Home Corner, and extends down and to the right from that point.

v
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Plotting on large surfaces (where the AxiDraw sits directly on the surface):
Position the AxiDraw such that the pen tip is at the upper left corner of the area
that you intend to plot upon. The software will treat the corner of the page in
your Inkscape document as Home Corner for the purpose of plotting.

Here is how the “page” printed above looks from within Inkscape:
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Plotting on everything else (letters, envelopes, invitations, and smaller items):
Position the paper with its upper-left corner directly underneath the tip of the
pen. Square the paper up so that its top edge is parallel to the base of the Axi-
Draw.

As we discussed earlier (page 28), documents that are taller than wide are usually
turned “sideways”, asin B above. Whether vertical or horizontal, itis always the cor-

ner of the paper closest to the Home Corner that one aligns below the tip of the pen.

For comparison, here are how those two documents look on the computer when
setting up to print:
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The absolute position of your paper with respect to the AxiDraw will vary, de-
pending on the paper, the pen that you use, as well as the pen length if it is
mounted at 45°. For any given pen and paper setup, it is likely to remain relatively
consistent. (See §6.5 Moving beyond the Clip Easel, on page 29.)
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9. Working with AxiDraw Control

In this section we will introduce the features and options in AxiDraw Control, the
primary interface to the AxiDraw. It can be found within your Inkscape menu at
Extensions > AxiDraw Control

AxiDraw Control has a tabbed interface, where the different tabs contain differ-
ent settings or control different functions.

One option, Preview mode, is available in every tab. It can be enabled by checking
the box. When checked, Preview mode simulates plotting only, letting you see
how your document will plot. You can read more about preview mode in “9.6 The
Notifications tab and Preview mode” on page 50.

9.1 Plotting the document

® O AxiDraw Control

Plot Setup Options Manual Layers Resume

AxiDraw Control
Press "Apply" to begin plotting. Use other tabs to adjust
settings and access additional AxiDraw functions.

AxiDraw documentation is online at: axidraw.com/docs . For technical
support, email contact@evilmadscientistcom or visit axidraw.com/chat

Copies: CopiestoPlot: 1 ==
Page Delay (s): 156 —-

Tip: Select 0 copies to plot continuously.

Version 3.9.0 — Copyright 2023 Evil Mad Science LLC

Preview mode (Simulate plotting only)

Close Apply

To plot your document, select the Plot tab and click Apply. This will plot the en-
tire document, including all visible layers.

The Plot tab contains two options: Copies to Plot and Page Delay, which are used
when plotting multiple copies of the same document.
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If Copies to Plot is set to a value greater than 1, then the AxiDraw will plot the
document that number of times, with an optional delay between copies.

Copies to Plot is a particularly helpful feature when using AxiDraw as a signature
machine, or for similar quick repeating tasks: you can have the machine sign each
document with just a time delay between documents.

9.1.1 Number of copies

Enter the number of copies that you would like to plot in the Copies to Plot box.
The default value, 1 copy, will only plot the document once. (You can print the
same document multiple times by pressing Apply to start each one.)

As a special case (noted as a “Tip” on the Plot tab), if you set the number of cop-
ies to O (zero), the AxiDraw will plot continuously, with the given delay between
pages, until you press the physical pause button on the left side of the AxiDraw.
(See §9.2 Pausing, resuming, and canceling plots, on page 40 for more about
pausing.)

If you use this continuous plotting mode, we recommend that you press the
pause button during the delay between plots, while the AxiDraw is resting at the
home position.

9.1.2 Page Delay

The value of Page Delay sets how long the AxiDraw will pause between pages
when plotting multiple copies. This delay is intended to allow time for you to swap
out the paper between copies. The default value is 15 seconds, but it can be set
anywhere from O (no added delay) to 3600 seconds (1 hour).

Applicability of multiple copies:

These two parameters, Copies to Plot and Page Delay, apply only when plotting
the document from the Plot or Layers tabs. They have no effect on other func-
tions.
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9.2 Pausing, resuming, and canceling plots

To stop a plotin progress, press the pause button: the raised silver-colored button
located on the left hand side of the AxiDraw. (See the pictures on page 13.)
The AxiDraw will stop plotting and raise the pen after finishing the current line
segment. The plotting progress is saved within your document.

Note: You must physically press the pause button to stop a plot in progress.
(Inkscape has a “Cancel” button, but it does not stop running extensions.)

Once paused, you can make adjustments in the settings (for example, to the pen
height or plotting speed), before resuming, if you choose to do so.

9.2.1 To resume after pausing

To resume a plot after pausing, open the Resume tab of AxiDraw Control, select
the Resume action and click Apply.

O ® AxiDraw Control

Plot Setup Options Manual Layers Resume

Pause and Resume

To pause a plotin progress, press the pause button on the left side of the
AxiDraw. After pausing, you can change settings or perform any manual
adjustments that are needed.

To resume plotting, or to simply cancel and return the carriage to the Home
Corner, press "Apply" with this tab selected.

Plot progress is stored in the SVG file itself. If you plan to quit Inkscape and

resume later, save the document first.

You can resume directly where you paused, or after using the Return to Home
Corner command.

Action on "Apply": © Resume (From Home or where paused)
Return to Home Corner (only)

Preview mode (Simulate plotting only)

Close Apply

9.2.2 To return to the Home Corner after pausing

To return the carriage to the Home Corner after pausing, select the Return to
Home Corner option and Apply. The plot can still be resumed after moving back
to Home (if, and only if, moved by this command).
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9.2.3 Canceling a plot

It is not necessary to take any action to cancel a plot that has already been
paused. However, you do still need to return the carriage to Home before begin-
ning a new plot.

You can return the carriage home using Return to Home Corner on the Resume
tab (as described in the previous section), with the Walk Home manual command
(page 67), or by hand.

If you need to move the carriage Home by hand, remember to unlock the mo-
tors so that the carriage can be moved. To do so, you can either use the dedi-
cated utility at AxiDraw Utilities > Disable XY Motors or select the Setup tab in
AxiDraw Control and use Raise pen, turn off motors.
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9.3 Plotting with multiple layers and colors

By default, the AxiDraw will print all visible paths in your document. A document
can, at your option, be organized into multiple layers. When you use the Plot tab
to print a document with multiple layers, each visible layer will print, and the or-
der of printing is from lowest layer first to highest layer last.

You can also use AxiDraw Control to plot a single layer, or some specific set of
layers. These methods are particularly useful for organizing and plotting docu-

ments that require multiple pens or colors.

9.3.1 Inkscape’s Layer menu

To create layers and move objects
between them, you can use the com-
mands in Inkscape’s Layer menu,
shown at right.

The commands in this menu let you
add, remove, and re-arrange layers as
you see fit.

You can also use the “Move Selec-

tion” commands in this menu to move
objects that you have selected to a
different layer.

To see a list of the layers in the docu-
ment, as well as to see which layer the
selected object is in, you can open
the Layers and Objects panel by se-
lecting it from this menu.
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9.3.2 The Layers and Objects panel

You can open the Layers and Objects panel by selecting from the menu:
Layer > Layers and Objects...

Create new layer

‘= Layers ang/Objects x Vv
View only layers - Move or

— = 2 A v 0 delete layer

[ 1-yellow I
[M 3-Red a8 I <@ Locked layer
4-blue < <@——— Hidden layer

[ 5-green I

—I <& Unlocked layer
TVisibIe layer

The Layers and Objects panel lists the layers in the document and the objects
within those layers. You may wish to press the button that we have labeled “View
only layers”, to only show the layers.

Within this panel, you can add, remove, re-order and rename layers. You can also
hide and show individual layers, an lock and unlock layers.

The document shown here, one of the AxiDraw example files, has five layers with
different names. (We have also hidden one layer and locked one layer to show
what that looks like.)

Note the little “eye” symbols, to the right of the some layer names. An “open
eye” symbol (or no symbol) indicates that the layer is visible. A “closed eye”
symbol indicates that a layer is hidden. Click the eye to show or hide an individual
layer. Hidden objects (including layers) will not be printed; hiding layers is one of
the simplest ways to plot only certain parts of a document.

The “lock” symbols to the right of the eye symbols indicate if a layer is locked. A
locked symbol (closed padlock) indicates that the layer is locked and cannot be
changed. You can click the lock symbol to lock or unlock a layer.

The Layers and Objects panel allows you to rearrange layers in different ways,
including adding sublayers inside of other layers. Like regular layers, sublayers can
be hidden or shown to isolate parts of your document for printing.
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9.3.3 The Layers tab in AxiDraw Control

In addition to hiding and showing layers, you can select which layers to plot with
the Layers tab of AxiDraw Control:

® [ ] AxiDraw Control

Plot Setup Options Manual Layers Resume

Plot Individual Layers

Normally, all paths, from all visible layers will be plotted.

You can also choose to plot a single layer or group of layers, for example to
plot only a single color of ink.

Press "Apply" with this tab selected to plot only the visible layers whose
names begin with the selected number, which can be in the range 0 to 1000.

For example, a layer named "5-red" will be plotted if the number 5 is selected,
but layers named "guide lines", "55", or "2-black" will be skipped.

Plot only layers beginning with: = 1 —

Tip: Number of copies to plot and the time delay between them are given by
parameters in the "Plot" tab.

Preview mode (Simulate plotting only)

Close Apply

The Layers tab has a single numeric input field, “Plot only layers beginning with:”.
When you click Apply with this tab active, the AxiDraw will only plot layers with
names that begin with the number entered in that field. Give layers that you wish
to print this way names that begin with an integer in the range O through 1000.

After plotting with the Layers tab, you can change any settings that you wish to,
or switch to a different pen, and then plot other layers. This makes it possible to
plot portions of a document with different colors and (e.g.,) speeds.

Example: Suppose that a document has three layers with the names,
1- Red circles
1- Red squares
2 - Blue stars

Then, you could plot the two red layers with a red pen by specifying “1”in the Plot
only layers beginning with field. You can then change the pen to blue and plot
the blue layer by specifying “2” in that field. Click the Apply button each time to
begin plotting of the selected layers.

Note that only “top-level” layers, not sublayers, can be selected for plotting by
the Layers tab of AxiDraw Control.
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9.3.4 An example with multiple colors

The set of layers shown in the Layers and Ob-
jects panel here page corresponds to the exam-

“= Layers and Objects x

ple below: A birthday party invitation with six : = A
colors and six layers. We have used the layer ;
. . . [ 1-yellow
numbering scheme from the previous section.
[ 3-Red
4-blue
You can see how it appears in Inkscape (top), as O S-green
well as printed on the page (bottom) using six O 2-black
ultra-fine point Sharpie markers, one per layer.
00 %
ANNA IS HAVING
A BIRTHDAY PARTY...
AND YOURE INVITED!
Mareh 19, 600 PM @Anna's
(1337 Spring Lane) RSVP!
dm "
;';‘." \a '_ s W
:\_*..:‘: T —
ANNA IS HAVING
A BIRTHDAY PARTY...
AND YOU'RE INVITED!
Mareh 19, 6:00 PM @A

(2270
O (1S

pring Lane) ' RSVK

v

v

i
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9.3.5 Multiple copies from the layers tab

The Copies to Plot and Page Delay parameters in the Plot tab do apply when you
plot from the Layers tab. That means that you can plot the same layer or set of
layers multiple times, in the same fashion as plotting multiple copies from the
Plot tab. (See §9.1 Plotting the document, on page 38).

9.3.6 Additional layer control features

Beyond control with the Layers tab, there are additional commands and parame-
ters that can be specified through the layer name.

You can use properly formatted codes to specify the pen-down height and the
speed for printing specific layers. There are also special codes that can introduce
a timed delay while plotting or force a programmatic pause (as though you had
pressed the pause button to halt a plot). These types of codes are rarely used in
everyday plotting, but can be useful in developing specialized applications.

One additional, and particularly useful, feature is that any layer with a name start-
ing with a percentage sign “%” is designated as a documentation layer, and will
never be plotted.

The Layer Control features are always active, and can be used (for example)
whether you are plotting from the Plot or Layers tab of AxiDraw Control. Just as
with plotting from the Layers tab, Layer Control features only work on the names
of “top-level” layers, and not sublayers.

The complete syntax for AxiDraw Layer Control can found at:
https:/wiki.evilmadscientist.com/ALC
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9.4 The Speed tab

The Speed tab of AxiDraw Control lets you set the basic movement speeds for
the AxiDraw. These include the speed limits and acceleration rates used for the
horizontal (XY) carriage motion, as well as an option to disable acceleration.

The Speed tab is one of several “sub tabs” under Options:

o (@] AxiDraw Control

Plot Setup Options Manual Layers Resume

Speed Pentiming Notifications  Advanced  Config

Movement speeds:
Writing/Drawing speed (%): 25 —
Pen-up movement speed (%): 75 —-|-
Acceleration : Standard w

Use constant speed when pen is down

Preview mode (Simulate plotting only)

Close Apply

Clicking the Apply button with the Speed tab selected has no effect; settings are
saved automatically, and clicking Apply does not initiate a plot or other function.

The first item in the list, Writing/Drawing speed, sets the maximum speed that
will be developed when the pen is down. The second, Pen-up movement speed,
sets the maximum speed that will be used when the pen is up, traveling between
two points.

The default value for these two speeds are 25% and 75%, respectively. You can
adjust these speeds. Keep in mind that - just like writing by hand - there will al-
ways be a trade-off between speed and neatness.

The Acceleration parameter controls how quickly the pen will approach these
maximum speeds. It is at least as important as the speed limits in determining the
total time that a plot will take.
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§9.4, The speed tab, continued

The Use constant speed when pen is down option, when checked, disables ac-
celeration and moves the pen at a constant speed when it is down. That speed
is controlled by the Writing/Drawing speed parameter above it. Constant speed
mode will give neater performance for certain types of paths, but uses a lower
overall speed scale. None the less, it is sometimes the fastest way to plot, de-
pending on the nature of the your work. The option is unchecked (disabled) by
default.

9.4.1 Suggested starting speeds

Everyday use:
Most of our sample drawings and tests are made with a medium speed that is
a compromise between speed and precision. This is a good balance for fine-
point permanent markers and wide-nibbed fountain pens:
Writing/Drawing speed: 30%
Pen-up movement speed: 75%
Acceleration: Standard

Working with precision:
When working with fine point pens and tuning for higher precision (with writ-
ing or drawing) a good starting point might be:
Writing/Drawing speed: 15%
Pen-up movement speed: 60%
Acceleration: Slow

Working at high speeds:
When using wide-tipped permanent markers or other writing implements
that make broad marks, one might go as high as:
Writing/Drawing speed: 90%
Pen-up movement speed: 100%
Acceleration: Maximum

There are additional factors besides speed that influence precision. These factors
include the pen lift and lowering speeds, the weight of your pen, where on the
page you are plotting, and so forth. The “right” speed to use for any given appli-
cation is one that gives you high enough output quality at an acceptable rate.
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9.5 The Pen timing tab

The Pen timing tab under Options has parameters that control the vertical mo-
tion speed between the heights set in the Setup tab (page 33). As with the
Speed tab, this is an options tab for which Apply has no effect.

@ [ ] AxiDraw Control

Plot Setup Options Manual Layers Resume

Speed Pen timing Notifications ~ Advanced  Config

Pen raising and lowering rates:

Pen raising speed : Maximum w

Pen lowering speed : Standard w

Optional delay after raising pen (ms): | 0 —_ +

Optional delay after lowering pen (ms): 0 _— +

Preview mode (Simulate plotting only)

Close Apply

The pen raising and lowering speeds can each be selected from a drop-down
menu, with options Maximum, Standard, Slow, Very slow, and Dead slow.

The AxiDraw pauses horizontal motion while raising or lowering the pen, until
that motion is complete. These pauses prevent it machine from making pen-up
movements until the pen is actually clear of the paper, and also prevent pen-
down movements from beginning until the pen is touching the paper.

If you are trying to increase the speed of your plots, be aware that the total ver-
tical travel distance is an important factor in how long pen lifting and lowering
takes. Thus, try to decrease the vertical range first, and look at the speeds next.
Slower lifting (and especially) lowering can potentially lead to neater writing and
prolong the life of the pen-Ilift motor as well as your pen tip.

You can add an optionally additional delay after raising or lowering the pen. How-
ever, in most cases, these delays should be kept at zero. Adjusting the pen height
positions and/or the physical location of the pen are preferred methods of en-
suring that it is positioned correctly at the correct time.
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9.6 The Notifications tab and Preview mode

The Notifications tab under Options has controls for rendering previews, report-
ing real or estimated plot time, and sending online notifications. Like the Speed

and Pen timing tabs, this is an options tab where the Apply button has no effect.

(@] © AxiDraw Control

Plot Setup Options Manual Layers Resume

Speed Pen timing Notifications Advanced Config

Rendering and reporting:

Report time elapsed

Preview mode rendering:  All movement v

Webhook notifications:

Post to webhook when a plot finishes

Webhook URL:

Preview mode (Simulate plotting only)

Close Apply

9.6.1 The Report time elapsed option

When the Report time elapsed option is checked, a dialog box will report the
elapsed time and pen-travel distance after each plot, or plot preview, finishes.
This option is particularly useful in preview mode, where it can provide a reason-
ably accurate estimate of the total time that will be needed for a plot. You can use
preview mode, with different options selected, to see how they influence total
plot time for your particular document.

9.6.2 Preview mode and preview mode rendering

Preview mode (Simulate plotting only)

Preview mode can be enabled by checking the box at the bottom of AxiDraw
Control is checked. When enabled, most everything will work normally, with the
significant exception that the software will not connect to or drive the AxiDraw.
Preview mode can be useful to test workflows, estimate timing, or otherwise pre-
view how the AxiDraw will plot a document, even without the AxiDraw present.
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To run a plot preview, enable the option and then press Apply on the Plot, Lay-
ers, or Resume tab to initiate a plot as you normally would. Certain modes and
commands that are primarily designed to communicate with the AxiDraw over
USB — including most in the Setup and Manual tabs — are unavailable while in
preview mode.

An option available in preview mode is Preview
mode rendering. If it is enabled, then the route of \
the AxiDraw across the page will be simulated and =~ Pen-down movement
drawn when a preview is run. Pen-up movement

Preview mode rendering is enabled by selecting a one

value other than None from its drop-down menu,
which has options All movement, Pen-down move-
ment, Pen-up movement, and None. The default is All movement.

When a preview is run and Preview mode rendering is enabled, then the selected
portion of the plot (pen-down movement, pen-up movement or both) will be
simulated and drawn on your page in a non-printing “documentation” layer when
you run the preview. When previewing multiple pages, only the last is drawn.

Here is how the example file AxiDraw_First.svg renders when you click Apply

from the Plot tab with preview mode enabled and the All movement rendering
option selected:

AXTDRAW

The pen-down movement is shown in blue, and the pen-up movement is shown
in light red.
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9.6.3 Working with rendered previews

You can use the Layers and Objects panel (from the Layer menu) to hide, show,
or remove the preview layers. Each time that you render a new preview it will
overwrite the old one.

“= Layers and Objects x v

= X A VvV T
¥ [ % Preview

[ Pen-down movement

[ Pen-up movement

| Layer1

The pen-down drawing and pen-up drawing portions are rendered as separate
sublayers within the Preview layer, so that you can hide one, the other, or both.
(If you don’t see the sublayers in the list, use the triangle next to “% Preview” to
expand its sublayers.)

Since previews are rendered within a documentation layer, these layers will not
plot on the AxiDraw, nor will their contents be rendered as part of future preview
renders. For more about documentation layers, see “9.3.6 Additional layer con-
trol features” on page 46.

Preview layers are erased and overwritten every time that you run a new preview.

Do not add any graphics or information that you want to keep to existing preview
layers, as they may easily be overwritten.
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9.7 Webhook alerts

The Notifications tab under Options supports webhook alerts, a somewhat ad-
vanced feature that can be used to provide mobile alerts (amongst other things)
when a plot finishes.

Once set up and enabled, the AxiDraw software can post to a specified URL
when a plot completes. This provides a method, when used in combination with
various third-party services, for generating notifications such as mobile alerts or
email when the AxiDraw finishes. Webhooks can also be used for custom integra-
tion with other software or hardware, to trigger other actions that should follow
a plot.

O @ AxiDraw Control

Plot Setup Options Manual Layers Resume

Speed Pentiming  Notifications  Advanced  Config

Rendering and reporting:

Report time elapsed

Preview mode rendering:  All movement v

Webhook notifications:

Post to webhook when a plot finishes

Webhook URL:  https:/url.to.post.to/

Preview mode (Simulate plotting only)

Close Apply
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§9.7, Webhook alerts, continued

To set up webhook alerts, enter the URL for the webhook in the Webhook URL
field and then check the Post to webhook when a plot finishes check box.

Webhook alerts are only generated when a plot ends, by completion or being
paused, when all four of the following conditions are met:

1. A document is being plotted with the Plot, Layers, or Resume tab,

2. The document is being physically plotted, with preview mode disabled,
3. Webhooks are enabled, via the check box, and

4. A Webhook URL is provided

Various internet services exist, both free and paid, that allow one to trigger dif-
ferent actions upon receipt of a webhook post. Three services that we are aware
of, IFTTT (ifttt.com), Integromat (integromat.com) and NTFY (ntfy.sh), offer free
tiers that support webhooks. Paid services that support webhooks include Zapier
and Automate.io.

Additional information about the webhook alerts feature can be found in our wiki,
at https://wiki.evilmadscientist.com/webhooks

9.7.1 Setting up webhooks with IFTTT

Extended documentation on our wiki walks through the process of setting up an
IFTTT account to receive webhook posts from the AxiDraw software and send
app-based mobile alerts.

If this is of interest to you, you can read about it in detail on our documentation
wiki, here: https:/wiki.evilmadscientist.com/webhooks
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9.8 Advanced options

The Advanced tab under Options has additional options that control the behavior
of plots. As with other tabs under Options, pressing the Apply button with the
this tab selected has no effect. (This tab on its own does not initiate a plot, per-
form plot optimizations, or any other action.)

[ ) @® AxiDraw Control

Plot Setup Options Manual Layers Resume

Speed  Pen timing Notificatons ~ Advanced  Config

Advanced Options:
Auto-rotate page when printing
Randomize starts of closed paths

Hidden-line removal
Plot optimization: ~ Least; Only connect adjoining paths v
Motor Resolution: ~2870 DPI (Slightly smoother) w

Tip: Hidden-line removal can be slow. It also ignores path
orientation, so full optimization is recommended.

Preview mode (Simulate plotting only)

Close Apply

Auto-rotate page when printing (Default: on)

Documents taller than wide (those in portrait orientation) are normally rotated
sideways when plotted. (See §6.3 Document orientation, on page 28 for ex-
amples.) To force documents to always print in the same orientation as on your
screen, uncheck this box.

Randomize starts of closed paths (Default: off)

A pen may form a visible mark at the location where it is lowered or raised. In
artwork where the same closed shape is repeated many times, that can cause a
seam-like visual artifact if many of those marks line up at matching points on the
repeated shapes.

When this option is enabled, the start position of closed paths — ones like circles,

rectangles, and squiggles that form a full loop with no obvious start or end point
— will be randomized, which can help to hide that specific type of visual artifact.
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§9.8, Advanced options, continued

As a demonstration of randomizing starts, examine the two figures below, each
consisting of ten concentric circles and plotted with a red pen on the AxiDraw.

Randomize starts: Off Randomize starts: On

The circles on the left were plotted with the randomize starts option turned off,
asis default. Starting at the center of the circles and looking to the right, you may
be able to see a small visual artifact where the pen set down and lifted at each
circle.

The circles on the right were plotted with Randomize starts enabled. The visual
artifacts are still present, but they are less noticeable because they do not line up.

Hidden-line removal (Default: off)

This option enables a different graphical processing routine for the AxiDraw,
where paths hidden behind filled objects will not be drawn. It is discussed in §9.9
Hidden-line removal, on page 57.

Plot optimization (Default: Least; Only connect adjoining paths):
This option affects the order of plotting, which can be altered to reduce pen-up
travel time. It is discussed in §9.10 Plot order and optimization, on page 58.

Motor resolution (Default: ~2870 DPI)

The two options are for native resolution of about 1435 or 2870 steps per inch
(56 or 113 steps per mm). Both options are finer than what can be resolved with
pens. The 1435 DPI option is slightly faster, while the 2870 DPI option is slightly
smoother, giving a neater plot. The difference between the two settings is typi-
cally minor in practice.
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9.9 Hidden-line removal
Hidden-line removal

The Hidden-line removal option in the Advanced tab changes how documents
are processed, such that objects hidden behind other objects will not print.

By default, with this option disabled, the AxiDraw draws all paths in the SVG doc-
ument. The fill and stroke (outline) properties of individual objects are ignored. In
other words, all paths are normally plotted as though each has a stroke and no fill.

When Hidden-line removal is enabled, the AxiDraw software will instead plot
paths only if (1) they do have a stroke applied to them, and (2) they are not oc-
cluded behind filled objects. An object that does not have a stroke property (e.g.,
no outline in Inkscape) will not plot, nor will one hidden behind a solid fill. The
example below illustrates these differences.

Appearance in
Inkscape:

Default behavior: Hidden-line removal enabled:

\

U

There are two important factors to bear in mind. First, Hidden-line removal re-
quires additional processing time before plotting, especially in instances with
large numbers of objects to process. (When you don’t need this feature, leave
it turned off.)

Second, the Hidden-line removal processing routine does not preserve the ori-
entation of individual SVG strokes. When you use it, we generally recommend
also using the Plot optimization option, set to Full; Also allow path reversal,
for efficient plotting.
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9.10 Plot order and optimization

The Plot optimization option in the Advanced tab can re-order elements in your
document to reduce pen-up travel, and thereby reduce total plotting time.

9.10.1 How plot order is determined

Elements within a document are normally plotted in the same order in which
they appear in the file. This order is generally the order in which the objects were
created; it might also be referred to as “bottom to top.”

For example, draw a circle and then a rectangle. Then, the AxiDraw will plot the
two objects in the order that you created them: The circle will plot before the
rectangle. The rectangle can also be described as being “above” the circle— a
description that makes sense if you imagine painting one object and then paint-
ing the other on top of it.

You can use the tools in the Object menu to rearrange the order of objects, for
example with the Object > Raise and Object > Lower menu commands. If you
raise our example circle above the rectangle, the rectangle will plot first.

If a document has multiple layers, lower layers plot before higher layers; you may
wish to open the Layers panel to see their order for reference.

9.10.2 The Plot optimization option

The Plot optimization drop-down menu in the Options tab has four items:

Plot optimization: Least; Only connect adjoining paths
Basic; Also reorder paths for speed
Full; Also allow path reversal

None; Strictly preserve file order

« Least; Only connect adjoining paths (default)
«  Basic; Also reorder paths for speed

«  Full; Also allow path reversal

«  None; Strictly preserve file order

By default, Plot optimization is disabled, and objects in the document will be plot-
ted in the order given by the file. However if either “Basic” or “Full” is selected,
then elements within the file will be reordered to reduce pen-up travel when you
run a plot or plot preview from the Plot, Layers, or Resume tab. Detailed descrip-
tions of these options follow in the next sections.
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The optimization routine is layer-aware: It will only re-order objects within layers.
That makes it safe to use on multicolor plots where colors are separated by lay-
ers. (See §9.3 Plotting with multiple layers and colors, on page 42.)

Changes to the order of elements during Plot optimization feature are ephem-
eral. A temporary copy of the file is created and re-ordered when you plot; no
changes to the order of elements in your file are retained.

Aside: There is an advanced method to save a file after optimization, for when
that’s important. See §10.7 Plot Digest (Plob) Export, on page 75.

9.10.3 Default: Least; Only connect adjoining paths

If the default option, Least; Only connect adjoining paths is selected, then paths
in the document will plot in the same order and (if Hidden-line removal is dis-
abled) direction as given in the document.

One exception to note is that if one path ends right where another begins (on the
same layer), those paths will be joined together, reducing the number of pen lifts
needed. To disable path joining, select None; Strictly preserve file order.

9.10.4 Basic; Also reorder paths for speed

If Basic; Also reorder paths for speed is selected, the plotting order of objects
within your document will also be altered to reduce pen-up travel.

Every graphical element within each layer will be broken into its constituent pen-
down strokes, or “subpaths”, and those subpaths will be re-ordered. This optimi-
zation option preserves the direction of each subpath, if Hidden-line removal is
disabled: Each subpath will be plotted from its start to its end, in the same direc-
tion that it appears in the file. For paths that are drawn by hand, this direction is
normally the same direction in which it was initially drawn.

9.10.5 Full; Also allow path reversal

If Full; Also allow path reversal is selected, the same re-ordering processes are
used. However, during the re-ordering process, the direction in which individual
sub-paths are drawn may be reversed to reduce pen-up travel time. This option
generally leads to the fastest overall plotting time. See page 62 for a visual
example of how this works.

9.10.6 None; Strictly preserve file order

The None; Strictly preserve file order option disables all re-ordering and path
joining methods. Paths will plot in the order and (if Hidden-line removal is dis-
abled) direction as given by the document. This option is chiefly useful in scien-
tific or engineering applications, or specialty use cases such as re-inking a brush,
where the order of operations is programatically determined.
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9.10.7 Example: Previews and optimization

When managing complex plots, it may be helpful to use Preview mode (see §9.6.2
Preview mode and preview mode rendering, on page 50) with rendering of
pen-up travel enabled and the Report time elapsed option, in order to preview
what the plot order looks like and estimate the plotting time.

As an example, here a stipple plot, created with StippleGen, consisting of 2000
filled circles and laid out on a letter-size sheet of paper. For this example, the
stacking order of the stipples within the file has been randomized, such that there
is only a random order to which the filled circles appear in the file and how they
will normally print.

If we now enable preview mode with pen-up travel rendered (and plot optimiza-
tion off), and run a preview using the Plot tab, we get the following mess, where
the red lines represent pen-up travel:
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The time report from this plot reads as follows:
Estimated print time: 43:49 (Minutes, seconds)
Length of path to draw: 16.258 m
Pen-up travel distance: 253.032 m
Total movement distance: 269.290 m
This estimate took 1.841 Seconds

As you can see by the numbers and the pen-up travel (shown in red), this plot is
dominated by pen-up travel. Only about 6% of the travel is with the pen down.

If we now enable plot optimization, selecting “Full” reordering and go back to the
Plot tab to run the plot, we get the following, more pleasing result:

With optimization enabled, the statistics are as follows:
Estimated print time: 19:33 (Minutes, seconds)
Length of path to draw: 16.258 m
Pen-up travel distance: 10.931 m
Total movement distance: 27.189 m
This estimate took 1.992 Seconds

Thus, with the option enabled, this particular plot now takes less than half the
time: 20 minutes instead of 44. And, about 60% of the travel distance is spent
with the pen down.

Aside: While this is a stark example, many real-world documents do exhibit
this level of initial disorder, for example when you start with scanned and
traced artwork, or documents generated programatically.
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9.10.8 Example: Path reversal

The path reversal option in Plot optimization can significantly improve perfor-
mance in some circumstances. This example drawing has 22 slightly varying
curves, each drawn in the same direction, from top to bottom:

s

If we plot this with Preview mode and plot optimization set to Basic; Also reorder
paths for speed, it neatly organizes the curves, and plots each of them in the
original direction, top to bottom:

As you can see from the amount of (red) pen-up travel, a significant amount of
the total motion is with the pen up.

We can get a much more efficient result by using the Full; Also allow path rever-

sal option for Plot optimization:
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9.11 The Config tab

The Config tab under Options allows you to specify which model of AxiDraw
hardware you are using, specify which particular AxiDraw to plot to (if you are
managing multiple machines), and check for software updates.

O o AxiDraw Control

Plot Setup Options Manual Layers Resume

Speed Pen timing Notifications ~ Advanced Config

Hardware configuration

AxiDraw model: AxiDraw V2, V3, or SE/A4 w

Pen-lift servo: Default A 4

Machine selection: = Use First AxiDraw located w

AxiDraw name or port:

Press "Apply" with this tab selected to check online for updates.

Preview mode (Simulate plotting only)

Close Apply

9.11.1 Selecting your AxiDraw model

Use the AxiDraw model drop-down menu to se-
lect which A><|Dra.\wvmode| you are using to con- | 4 iDraw V2, V3, or SE/Ad
figure the travel limits for the AxiDraw hardware.
AxiDraw V3/A3 or SE/A3
Options in the AxiDraw model AxiDraw V3/B6
drop-down menu:
AxiDraw MiniKit
. . . AxiD SE/A1
If you have a special-order AxiDraw that is not =
listed in the drop-down menu, please contact AxiDraw SE/A2
technical support about adjusting for the size of AxiDraw V3 XLX

your machine.
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9.11.2 Pen-lift servo option

Pen-lift servo: Default [N

. . Standard (lowest position)
Machine selection:

Brushless (3rd position)

AxiDraw name or port:

Use the Pen-lift servo drop down menu on the Config tab to select your pen-lift
servo motor configuration, if other than standard for your AxiDraw model.

If your AxiDraw has a Brushless pen-lift servo motor upgrade, select it from this
menu to enable that option. For all other uses, including units with a coreless
servo upgrade, leave this option set to Default.

9.11.3 Machine selection

There are two additional controls in the Config tab that are useful when working
with multiple AxiDraw machines: the Machine selection drop-down menu and
the AxiDraw name or port text input box.

Machine selection: Use First AxiDraw located

Use AxiDraw named below
AxiDraw name or port: =~ California L3

. Plot to all AxiDraw units

The Machine selection drop-down menu has three options:
o Use First AxiDraw located (default)
o Use AxiDraw named below
o Plot to all AxiDraw units

If Use First AxiDraw located (the default option) is selected, AxiDraw Control will

control the first AxiDraw located via USB. Keep this option selected if you are
working with a single machine.
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If Use AxiDraw named below is selected, AxiDraw Control will only look for and
drive a specific AxiDraw unit, as entered in the AxiDraw name or port entry box.
Use this method when you have multiple AxiDraw machines and want to plot to
a specific machine.

The name or port may be specified with a USB nickname - like “California” as
entered above - or with a traditional enumerated serial port name like “COM6”
on Windows or “/dev/cu.usbmodem1441” on a Mac. Since serial port names can
change, it is best practice to use a USB nickname when working with multiple
AxiDraw machines. (For more about USB nicknames, see §10.1 AxiDraw Naming,
on page 69.)

If Plot to all AxiDraw units is selected, a document that is plotted will be simul-
taneously sent to all detected AxiDraw units. Use this option when you have
several AxiDraw machines and wish to plot the same document, simultaneously,
on multiple machines. (A typical desktop-class computer can support up to 3-4
AxiDraw machines working simultaneously.)

When plotting the same document to multiple machines, any individual unit can
be stopped by pressing its physical pause button, but plots that are stopped gen-
erally cannot be resumed.

9.11.4 Check for updates

If you click Apply with the Config tab selected, it will query and report both the
versions of the AxiDraw software and the version of the Axidraw “EBB” firmware.
Additionally, this function will check online to see if newer software versions are
available. We do highly encourage you to update to the latest available version.

As of the most recent edition of this user guide, AxiDraw is shipping with firm-
ware version 2.7.0. If your EBB firmware version older is than 2.6.2, we do advise
that you update to a newer version. Please visit http://AxiDraw.com/fw for more
about updating firmware.
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9.12 Manual Controls

The Manual tab of AxiDraw Control allows you to manually execute several basic
and advanced commands and queries. Select the operation to perform from
Command drop-down menu, and then click the Apply button. For certain com-
mands, like the “walk” commands, you can also enter a distance.

[ ] [ ] AxiDraw Control

Plot Setup Options Manual Layers Resume Walk Carriage (X, inches)

Walk Carriage (Y, inches)
Manual Control Walk Carriage (X, mm)
Press "Apply" with this tab selected to execute various "manual" Axi
commands. For example, you can walk (move) the carriage, rais
pen, enable or disable the motors, or adjust the position wher
will be resumed.

lower the Walk Carriage (Y, mm)
Walk Home

Raise the Pen

Command: = Walk Carriage (X, inches) w Lower the Pen

Walk distance: 3.000 —4 Enable XY Motors

Disable XY Motors

Caution: The manual "walk" commands will move the carriage as reques
without regard to the current position. Moving too far or in the wrong direction
may cause AxiDraw to try and move beyond its physical limits of travel.

Enter Bootloader mode

Strip plotter data from file

Preview mode (Simulate plotting only)

Close Apply

The individual manual command functions are detailed in the following sections.

9.12.1 Walk Carriage commands

The first four manual commands in the menu are “Walk carriage” com-
mands that move, or “walk” the carriage in the X or Y direction by
the numeric distance given in the Walk or adjustment distance field:

Walk Carriage (X, inches), Walk Carriage (Y, inches)
Walk Carriage (X, mm), Walk Carriage (Y, mm)

The Walk or adjustment distance may be positive or negative, and you can choose
either inch or millimeter units by selecting the appropriate command.

The walk carriage commands can be used to make small calibration adjustments
to the carriage position before starting a plot. (The position where a plot starts
will be the origin for that plot.) The Walk Home command can be used to “reset”
any walks, returning to the carriage position where the motors were first enabled.
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The Home Corner is the X=0, Y=0 position, and positive moves in both X and Y
are both in the directions away from the home corner.

Important note: no limit checking is performed on manual walk commands; Take
care not to run the AxiDraw into its physical limits. If you are unsure, disable the
motors and move the carriage Home by hand.

9.12.2 Walk Home

The Walk Home command is a special “walk carriage” type command that moves
the carriage to the initial position where the motors were enabled.

In normal operation, where the AxiDraw is located in the Home position before
enabling the motors, starting a plot, or using other Walk Carriage commands,
Walk Home will return the AxiDraw to the Home position. But, if the motors were
enabled in some different position, this command will instead return the AxiDraw
to that position instead.

This command can be used to reset the AxiDraw carriage position — moving it
back to Home — after one or more manual walk commands or after pausing a
plot that will not be resumed.

Note: Changing the motor resolution option acts as “enabling” the motors,
and may alter the position that Walk Home will return to.

9.12.3 Raise the Pen, Lower the Pen

These two commands move the pen to the pen-up or pen-down position.

9.12.4 Enable XY Motors, Disable XY Motors

These two commands either energize the two stepper motors or turn power off
to them. The carriage can be moved by hand only when motor power is off. 67



9.12.5 Enter EBB Bootloader Mode

Command the EBB to enter “bootloader” mode. This utility mode is sometimes
used in reprogramming the firmware. If you should accidentally enter this mode,
disconnect the AxiDraw from both power and USB to reboot the AxiDraw.

9.12.6 Strip plotter data from file

The AxiDraw software stores certain configuration data within your document.
While having that data there does not cause any known issues, this command can
strip that data from the file, should that need arise.
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10. AxiDraw Utilities

In addition to AxiDraw Control, there are several additional utilities included with
the AxiDraw software. Most can be found in the menu under Extensions > Axi-
Draw Utilities.

¥

] 3 = L X
Arrange >
37 AxiDraw Control... n Il 2 H-lnoon
oiDraw Naming...
Color > Disable XY Motors
Document > Hatch fill...
EggBot > Hershey Text...
Export > Plot Optimization...
Gcodetools > Process lllustrator SVG...
N mmmmm +m frmimn Nkl -

10.1 AxiDraw Naming

The AxiDraw Naming utility allows you to assign a USB nickname to a specific
AxiDraw. It can be found in the menu at Extensions > AxiDraw Utilities > Axi-
Draw Naming.

A USB nickname is a semipermanent label, stored in the AxiDraw’s flash memory,
that may be used to identify and address it. Nicknames are not required, but can
be helpful if you have more than one AxiDraw connected: You can use them to
specify which AxiDraw to plot to when using AxiDraw Control.

Important note: Nicknames are semipermanent, but updating your AxiDraw firm-
ware will reset its configuration, removing any nickname that has been set.

@0 |X| AxiDraw Naming
Read AxiDraw Name | Write AxiDraw Name | About

Read AxiDraw Nickname

Click "Apply" to read and list all AxiDraw units found via
USB. Each is listed by assigned USB Nickname (if any) or by
USE port enumeration.

Close Apply




10.1.1 Read AxiDraw Name

If you click Apply with the “Read AxiDraw Name” tab selected, it will search for
all attached AxiDraw units and list them. AxiDraw machines will be listed by their
USB nickname or by their USB port enumeration, if no nickname has been as-
signed. This tool can be useful for listing available AxiDraw units, even if you are
not using USB nicknames.

10.1.2 Write AxiDraw name

® 0 |%/ AxiDraw Maming
Read AxiDraw Name = Write AxiDraw Name | About
Write AxiDraw Nickname

Nickname: California
Click "Apply" to assign the Nickname above to the AxiDraw
connected via USB. After the name change, the AxiDraw will
reboot to its power-on state, (If more than one AxiDraw is

connected, only the first one found will be updated.)

MNames should be 3-16 characters long.

Close Apply

A
T —

The second tab, “Write AxiDraw Name,” is for assigning a USB nickname.

To assign the USB nickname, enter a name between in the text box (here “Cal-
ifornia”) and click Apply. Before writing the name, it is recommended that you
disconnect any other connected AxiDraw units, so that you can be sure of which
AxiDraw you are communicating with.

Writing an empty name will clear the nickname.

You can use the “Read AxiDraw Name” tab to verify that the name has been
written correctly.

Assigning USB nicknames requires that your AxiDraw has firmware version 2.5.5

or newer. If you are unsure what version you have, you can check with AxiDraw
Control; see §9.11.4 Check for updates, on page 65.
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10.2 Disable XY Motors

This is a single-purpose “shortcut” command that turns off power to the pair of
motors that controls the XY position of the AxiDraw carriage. This motor power
is off by default at power up. It is often useful to turn off power to the XY motors
so that the carriage can be manually moved to the home corner, prior to plotting.

It can be found in the menu at:
Extensions > AxiDraw Utilities > Disable XY Motors.

This command is equivalent to using the Manual tab in AxiDraw Control, with the
Disable Motors command selected. (See §9.12 Manual Controls, on page 66.)

This shortcut command is intended for use with a single AxiDraw; it performs the
action on the first AxiDraw located via USB. If you need to perform this action
with multiple AxiDraw units, use the Manual controls in AxiDraw Control.

10.3 Hatch Fill

The Hatch Fill utility can be found in the menu at:
Extensions > AxiDraw Utilities > Hatch Fill

Its usage is described in §11.11 Filling shapes and text, on page 86.

10.4 Hershey Text

The Hershey Text utility can be found in the menu at:
Extensions > AxiDraw Utilities > Hershey Text

Its usage is described in §11.7 Hershey Text, on page 83.

10.5 Plot Optimization (Legacy)

This utility can be found in the menu at:
Extensions > AxiDraw Utilities > Plot Optimization (Legacy)

This is an older stand-alone version of the plot optimization option in AxiDraw
Control, described in §9.10 Plot order and optimization, on page 58. It chang-
es the order of plotting, so as to reduce pen-up travel.

Unlike the option built into AxiDraw Control, which temporarily re-orders the
document, this stand-alone tool changes the order of objects within the file so
that you can save the optimized document. This approach may be advantageous
if you plan to plot the same file many times. However, it does not allow optimiza-
tion within compound paths or have the ability to reverse paths.
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[ BON Plot Optimization (Legacy)
AxiDraw Plot Optimization Tool

This utility will re-order objects within each layer of your
document, to reduce pen-up travel distance and time.

Group Handling © Reorder within groups
Preserve groups
Break apart groups

v 2.8. Copyright 2021, Evil Mad Scientist

Close Apply

There are three options available for how groups should be handled:
«  Reorder within groups
«  Preserve groups
«  Break apart groups

The first option, Reorder within groups will re-order objects and groups within
each layer of your document. Grouped objects will remain grouped. But, objects
(and other groups) within any given group will be re-ordered.

If the second option, Preserve groups is selected, the plotting order of objects
within your document (including the order in which groups are plotted) may be
altered to reduce pen-up travel time. However, the order of elements within
groups will be preserved. This option can be useful if you have groups that you
wish to preserve the plot order within — for example if you have a line of text that
plots left-to-right — but otherwise wish to speed up plotting of the document.

If the third option, Break apart groups, is then all elements within each layer of
your document will be re-ordered for speed, just as though you had ungrouped
all elements before plotting. This option removes the groups from your file.

If you wish to visualize the pen-up travel and/or estimate the time that a plot will
take, you can do so with preview rendering and the report time option. See “9.6
The Notifications tab and Preview mode” on page 50.

Tip: To take advantage of the full optimization tools in the AxiDraw software
and save a file after optimizing, instead use the Plot Digest (Plob) Export
method, described in section §10.7 Plot Digest (Plob) Export, on page 75.
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10.6 Process lllustrator SVG

Adobe lllustrator users may notice two issues when working with SVG files im-
ported from lllustrator into Inkscape. First, Inkscape does not automatically rec-
ognize layers in lllustrator SVG files, and instead usually treats them as regular
groups. Second, the document and objects in it may be scaled down, at only 75%
of the correct size.

The AxiDraw software includes a special tool for correcting these two issues in
files imported from Adobe lIllustrator. It can be found in the menu at:
Extensions > AxiDraw Utilities > Process lllustrator SVG

When you run this extension, it automatically detects any named lllustrator layers
and sublayers in the file and converts them into named Inkscape layers an sub-
layers. It also detects if the file is displayed at the 75% scale, and if so, scales it
back to 100%.

The user interface of the Process lllustrator SVG extension provides a list of the
recommended steps to export SVG from Illustrator before opening it in Inkscape
and running this extension. Amongst these steps, it is recommended to pick layer
names in Al that contain at least one space, for example “1 Lemon” or “Lemon
yellow”, rather than “Lemon” or “lLemon”.

| BON Process lllustrator SVG
Process lllustrator SVG v 1.1

Apply this extension after opening an SVG file
exported from Adobe lllustrator to:

(1) Recognize and import named layers.

(2) Correct document scale, if necessary.
(lllustrator may export SVG at 75% of correct size.)

How to export SVG from lllustrator

For best results when exporting from Al:
* When naming layers in Al, either:
* Use just a number as the layer name, or
* Include a space in each name
* Use File > Export > Export As...
* Check the "Use Artboards" option
* Select the SVG format option and click Export
* Styling: Presentation attributes
* Object IDs: Layer names
* Minify, Responsive: Both off

Then, open the SVG file in Inkscape and Apply this extension.

Close Apply
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In lllustrator, export your file with:
File > Export > Export As...

Export for Screens...
Export As...
Save for Web (Legacy)...

_ X4 38S
Package... {4 38P

Then, select SVG format, and check the “Use Artboards” option when saving:

Format: SVG (svg)
Use Artboards °AII _ Range:

The SVG Options window is displayed as part of the saving process. In it, select
Presentation Attributes for styling, and Layer Names for Object IDs. Make sure
that the Minify and Responsive options are not selected.
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SVG Options

Styling: Presentation Attributes
Font: Convert To Outlines
Images: Preserve
Object IDs: Layer Names

Decimal: 4

[ Minify [J Responsive

Cancel

Technical aside: What’s different between lllustrator SVG and Inkscape SVG?
The SVG specification does not define layers. Rather, both lllustrator and
Inkscape use specially labeled SVG groups which act as layers. Unfortunate-
ly, lllustrator and Inkscape use different internal labeling schemes, which is
why layers do not come through automatically. The scale issue is a subtle
historical artifact. Illustrator has always used 72 pixels per inch as its conven-
tion, while Inkscape now (since version 0.92) follows the CSS-derived SVG
standard of 96. Under some conditions lllustrator will export files that are
defined in inches or millimeters, in which case files come in at the right scale.
In others, it exports as 72 pixels per inch, which causes the 75% scaling issue.



10.7 Plot Digest (Plob) Export

The AxiDraw software includes an advanced feature to export a “Plot Digest” or
Plob file. A Plob is a pared-down SVG file that the AxiDraw software “digests” the
file into, after processing, including any randomization and optimization steps. A
Plob file is this intermediate state of the document, saved just before plotting.

Opening and plotting from a Plob skips lets the AxiDraw software start (or re-
sume) plotting almost immediately. That can be helpful, for example, with very
large SVG files that take a while to process before plotting. You can also run pre-
views starting from a Plob file, with the same time savings for large files. Another
Plob use case is preparing and plotting files from different computers.

To export a Plob, select File > Save a Copy... in Inkscape and then choose file
format AxiDraw “Plob” Plot Digest (*.svg). You'll then need to select certain plot
options including the AxiDraw model to prepare the Plob for. Exporting a Plob
takes as much time that it would for the AxiDraw to begin plotting the file. How-
ever, you may be able to save that time when printing, since the AxiDraw soft-
ware can skip the initial processing and optimizations.

Save
Sl AxiDraw "Plob" Plot Digest (*.svg) v
Save a Copy...
[ ] o AxiDraw Plot Digest (Plob) Export

Plot Digest Options About

AxiDraw model: AxiDraw V2, V3, or SE/A4 w

Layer handling: Include all layers v

Specific layer selection: 1 —+4
Plot optimization: Full; Also allow path reversal v

Auto-rotate page when printing
Randomize starts of closed paths

Hidden-line removal

Version 3.9.0. Copyright 2023 Evil Mad Scientist

Cancel OK

Important note 1: Generating a Plob is destructive. Always save as a copy with a
new name and keep your original document .

Important note 2: You cannot make changes to a Plob after generating it. If you
do, it will no longer be recognized as a valid Plob (and not skip processing). In-
stead, modify and export a new Plob from your original document.
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11. Designing for AxiDraw

11.1 General considerations

The AxiDraw is a pen plotter, which is fundamentally a single function device. Its
sole function is to guide a pen (or other implement in the pen holder) along the
set of vector lines, curves, and paths that you ask it to follow. All other things that
the machine is ultimately capable of — such as drawing graphics, writing text, or
signing documents — are expressions of this basic function. It is capable of draw-
ing essentially anything that can be composed from a set of lines.

Certain object types are automatically treated as paths, for example circles and
rectangles. Other types of objects that are made of curves - like text - may need
to be converted from (editable) text into simple paths before plotting. You can
convert a selected object to a path by using the menu option Path > Object to
Path.

11.1.1 Objects that are not paths

The AxiDraw does not directly plot objects that are not made of paths. This in-
cludes pictures (raster or bitmap images, such as JPG, GIF, and PNG files), nor
effects such as fills, gradients, and background colors. These kinds of things re-
quire conversion to paths before plotting. That is straightforward in some cases,
and not in others.

Two notable helper tools are the Hatch Fill extension (see §11.11 Filling shapes and
text, on page 86) and the various tools for converting images into sketches
(see §11.12 Vectorizing images, on page 88).

11.1.2 Importing graphics

The native file format of the AxiDraw software is SVG (“scalable vector graphics”
- a standard interchange format). You can create artwork directly in Inkscape or
use other programs that can export SVG directly, such as Adobe lllustrator or
CorelDRAW. Inkscape can also import artwork in formats including EPS, DXF, Al,
CDR, and PDF.

If you encounter difficulties opening SVG documents into Inkscape, one ap-
proach that can help is to start with an empty document in Inkscape, and then
use the File > Import command to place your document. See the next section,
§11.2 Templates, on page 77, for more about empty documents.

It is worth noting that the file type itself is not always a reliable indicator of
whether or not the file suitable for use on the AxiDraw. For example, a PDF doc-
ument with vector paths from Adobe lllustrator will generally work very well,
but it is also possible to create a PDF that contains nothing but a picture in JPG
format. In the latter case, the image still isn’t vector graphics, even though it’s
tucked into a PDF file.
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11.2 Templates

When designing in Inkscape, it is recommended to create new documents by
using a template, for example an A4 or US Letter sized document. You can cre-
ate a basic document from a template by selecting File > New from Template,
selecting Blank Page from the left-hand list and then select your page size and
orientation.

| NON | New From Template

Blank Page...
Search: v

P ize: Letter — 8.5 x 11
A4 leatlet 3-fold Roll SRR | S xan e

about screen
Page orientation:  Vertical (Portrait) -
Business Card...

CD Label 120mmx120mm Page background: Normal v
default pt

default px
Desktop...

DVD Cover...
EggBot Template
Envelope...
Generic canvas...
Icon...

LaTeX Beamer

No Layers
Seamless Pattern...

Typography Canvas
Video... More info

Hide border

Empty page of chosen size.

Create from template

For other page sizes (not available within this panel), go to File > Document
Properties after creating a document. There, you can find a long list of standard
paper sizes that you can choose from.

If you frequently use page sizes that are not available in the Templates list, you
may wish to save blank documents to use as your own templates.
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11.3 Visualizing paths in your document

When working with documents containing mixed object types or styles, it can
be helpful to visualize all of the paths without their fills. This is especially helpful
when Hidden-line removal is disabled.

To see all of the paths in your document, select all in your drawing (From the

menu: Edit > Select all in all layers). Then, open the Fill and Stroke panel (Object
> Fill and stroke). In the Fill tab, select “No paint”, the icon with the “x”:

[« Fill and Stroke x v

l Fil [] Stroke paint == Stroke style

xHEHEREE?OV

No paint

Then, in the Stroke paint tab, select “Flat Color”. And, in the Stroke style tab,
select a consistent width, say 0.020 inches or 0.5 mm.

[ Fill and Stroke x v [# Fill and Stroke x v
W Fill [ Stroke paint  =* Stroke style W Fil  [] Stroke paint = Stroke style
xHEAEREE? OV Widm;mm-

Flat color S RGB ~ Dashes!  =—0Ho—w 000 -

Markers: v v v

Join: ‘F 73 IF 4.00
co @ A A
Order: .- '- ’

This procedure often provides a good visualization of how the AxiDraw will view
your page. However, it is not a precise representation of how plotting will work.
For example, it shows the outlines around objects even if they are not yet con-
verted to paths.

For a more exact preview of how your document will plot, you may wish to try

preview mode with rendering enabled (see §9.6.2 Preview mode and preview
mode rendering, on page 50).
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11.4 Fonts, characters, and languages

The AxiDraw is designed to trace the vector paths that you provide to it. The
document that you prepare may include any number and variety of different text
and graphical elements, so long as they are converted to paths before you plot
them.

As its sole function is to follow paths, the AxiDraw itself does not use fonts (built-
in or otherwise) nor does it have knowledge about any written languages. Thus,
it has no preference for one language over another, and is equally happy to write
in English, Japanese, or Arabic, so long as you can provide suitable input. Similarly,
you can use fonts in any typeface style or character set - including international
languages and including fonts that resemble handwriting.

Most fonts types like Truelype (TTF) and Openlype (OTF) that are installed on

your computer are usable directly within Inkscape. You can create and edit text

objects in Inkscape by selecting the text tool, which you can select

by clicking the icon shown here, or by using F8 on your keyboard.

AI You can select between available fonts using the Text and Font panel,
accessible in the menu at Text > Text and Font....

To convert editable text into paths that can be plotted, select the text elements
that you wish to convert. Then, choose from the menu Path > Object to Path.
You may wish to save a separate copy of your document before converting to
paths, in case you wish to edit the text again later.

i‘\J ’;«{’“\(j“

¢ I\, €
Ly

0\

&
[

-

This example was made using the font “Savoye LET” on a Mac.
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11.5 About outline fonts

All standard computer fonts — those found in formats including TrueType, Post-
Script, and Openlype — are outline fonts. In outline fonts, each character in the
font file describes a vector outline shape, which will be filled in by tiny pixels when
displayed on your screen or rendered by an inkjet or laser printer.

Things are different when you wish to use a pen plotter. As described in the pre-
vious section, you can easily convert outline font text into a set of paths for plot-
ting, and then plot it with the AxiDraw. When you do so, the machine will follow
the actual vector shape contained in that font file, which is that outline.

Below is a sample of text written in a common handwriting-like font:

outline Font Exa mple
ouwtline Fonk ExXa wple

The upper line of the sample shows the text filled in, as it will typically appear on
your screen, or when printed on a laser printer. The lower line shows the outline:
These are the actual vector shapes contained within the font file, and illustrates how
the output will look when printed with a pen plotter.

Now, if you had picked that handwriting-like font with the intent of creating hand-
writing-like output on the AxiDraw, this is probably not what you had intended.

The cause of this “unexpected” behavior is that one might easily (though mis-
takenly) assume that a handwriting-like font contains handwriting-like strokes.
The letters “t” and “x” both look like they could be made up of two strokes that
overlap, and the “O” looks like it could be a single loop. However, in order for
outline fonts to render correctly on your screen, the “t” and “x” are instead each
composed of a single (but complex) closed loop, while the “O” consists of two

closed loops, one inside the other.

To be quite explicit: there is absolutely no data contained within an outline font
that represents or corresponds to the visually apparent centerline of the char-
acters. This fact is consistent for all standard computer fonts, and will present no
unexpected behavior, so long as you are aware of it.
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11.5.1 Handwriting-like output with outline fonts

When trying to achieve output close to that of natural handwriting, an “outlined”
effect is generally not desirable. To mitigate it, pick handwriting-like fonts that
have a thin and consistent stroke width. If a font is available in multiple weights,
you'll want to pick the lightest (thinnest) one available. This, combined with the
use of a medium or broad nib pen can often make it so that the two sides of the
outline blend together.

Using a broad-point pen, particularly a broad-nibbed fountain pen, is the one of
the most effective ways to make a document look closer to hand written. It is also
helpful to pick a larger font size, closer to that of natural handwriting (perhaps 18
pt) as a starting point. When writing by hand, people tend to write much larger
than typical typed lettering.

If you would like to create a custom handwriting font based on your own hand-
writing, there are free services online (such as http:/calligraphr.com) that can
build fonts based on samples that you provide. Even so, note (1) that these are
standard (outline) fonts, and the advice above still applies. In most cases (2),
fonts automatically generated from your handwriting tend to be very crude as
compared to high-quality hand-crafted fonts.

11.5.2 Block and display output

In some cases you may wish to work with text that has large block letters, display
text, or other instances with characters that have a wide cross section. Text like
this will have a very visible outline, which you’ll usually want to fill in with ink.

The best way to do this is to use the Hatch Fill method, as described in §11.11
Filling shapes and text, on page 86. When you apply a hatch fill, it will create a
back-and-forth pattern for the pen to follow, to fill in the shape. While it may be

counterintuitive to fill in text this way, it is much closer to how outline fonts are
intended to be used: The outline is filled in with ink.

Block U@t
Block Text, Filled
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11.6 Stroke fonts

In addition to regular computer fonts (outline fonts), pen plotters like the Axi-
Draw can in some cases make use of a second class of specialized fonts, called
stroke fonts, or engraving fonts. In stroke fonts, each visible character is defined
by strokes of non-zero width, as opposed to the area within an outline.

While they do have some restrictions, stroke fonts are ideal for use with pen plot-
ters, since they plot efficiently (for example, the “0” is one loop, not two). They
are particularly suited for handwriting-like applications, because they can closely
mimic how humans write: Along the center lines of the text.

The following sample of text is rendered with a stroke font, using a special appli-
cation called Hershey Text. The second line is identical to the first, except that
we have colored the individual paths (strokes) within each character so that you
can tell them apart:

Stroke Text Example
Stroke Text Example

As you can see, characters like the “t” and “x” here are composed of two inter-
secting strokes. Similarly, a letter “o” in this font consists of a single loop. This
particular stroke font is a single-stroke font, since each visible line is made up of
only a single path. Some other stroke fonts instead use multiple strokes to con-
struct wider characters, e.g., bold fonts.

There two important drawbacks to stroke fonts. First, they are not regular com-
puter fonts, so they generally cannot be used in the same ways as other fonts.
You cannot, for example, install them as regular fonts on your computer nor use
them in word processors or graphics applications. Second (and mostly because
of that first reason) there are at present few available stroke fonts. Despite these
obstacles, stroke fonts are still worth mentioning: In cases where you can use
them, they are the best solution for using fonts with a plotter.
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11.7 Hershey Text

Inkscape includes a special application that we developed called Hershey Text,
which is capable of typesetting text in a small number of included stroke-based
fonts.

When you use Hershey Text, it takes editable text (that is, text that you type) and
replaces it with rendered stroke-font text: a set of vector paths that the pen can
follow. Once you have rendered text into paths, it can no longer be edited as
though it were text. (The paths can be edited with Inkscape’s path editing tools.)

You can find Hershey Text in the menu at
Extensions > AxiDraw Utilities > Hershey Text.

[ NON ) Hershey Text

Render Utilities About Credits

Hershey Text

A tool to replace text with stroke fonts

Version 3.0.2, 2019-09-07

Font face: EMS Allure v
Other SVG font name or path (if "Other" selected above):

Name/Path:

Preserve original text

Live preview

Close Apply

To use Hershey Text, start with a document that contains text objects. Select the
Render tab, and choose a font face from the drop-down menu. When you click
Apply, it will render all text elements on your page into the selected stroke-based
typeface. If you would like to convert only certain text elements, click Apply with
just those elements selected.

If the Preserve original text box is checked, then the original text elements on
the page will be preserved even when you click Apply. If it is unchecked, then the
original font elements will be removed once rendered.
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In addition to rendering text, you can use the Utilities tab of Hershey Text to gen-
erate a table of the single-stroke font faces that are available to use.

A full user guide for Hershey Text is available at:
https:/wiki.evilmadscientist.com/hershey

11.8 Hershey Advanced and AxiDraw Merge

Two commercial software tools are available at no added cost to AxiDraw own-
ers. To request a download link, please contact us directly:
https:/shop.evilmadscientist.com/contact

Hershey Advanced

Hershey Advanced is a more capable version of Hershey Text.

Like Hershey Text, Hershey Advanced performs font substitution in your doc-
ument, replacing text composed of regular computer fonts with plotter-ready
stroke-based lettering. It also offers the ability to introduce subtle “handwrit-
ing-like” defects, to help break the appearance of computer-generated writing.

AxiDraw Merge

AxiDraw Merge is software designed to automate certain workflows on the Axi-
Draw, and encompasses the primary capabilities of both AxiDraw Control and
Hershey Advanced.

AxiDraw Merge can, in a single step, perform stroke-font substitution on your
document using Hershey Advanced (complete with handwriting-like defects) and
plotit on the AxiDraw. It can plot the next document after a time delay or button
press.

You can also, optionally, use AxiDraw Merge to automatically populate a template
with data sourced from a CSV (spreadsheet) file, perform font substitution using
Hershey Advanced, plot the document, and repeat with data from specified rows
of your CSV file.
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11.9 Capturing signatures and handwriting

The best way to transform some handwritten text — whether a signature or a full
page of text — into something that the AxiDraw can plot is to use direct hand-
writing capture, or what you might refer to as “real-time” capture.

In direct capture, you use your computer to record each stroke as it is written,
and then save the resulting set of paths as a vector artwork file. This method can
also be used when replicating handwriting. For example when replicating histori-
cal signatures, it is necessary to trace along the strokes of existing writing and to
capture those strokes as you trace them.

For much more about ways to capture and trace handwriting — including a link to

jSignature, a program that can easily capture your signature in real time — please

see our detailed documentation on the subject:
http://wiki.evilmadscientist.com/capture

A'link to this page can also be found on our main documentation site,
http://axidraw.com/docs

11.10 Aside: Tracing of scanned handwriting

While we are frequently asked about this, it should be noted that there is not
any straightforward way of automatically converting scanned handwriting
into a set of high-quality vector paths that a plotter such as the AxiDraw can
follow. Simple approaches such as centerline tracing rarely approximate the
quality and character of real human handwriting.

This is a longstanding problem in artificial intelligence called “handwriting tra-
jectory reconstruction” Solving it is well outside of what the AxiDraw software
aims to support. (Again, the function of the AxiDraw is to plot the vectors that
you supply to it.)

When software that performs handwriting trajectory reconstruction becomes
available, the AxiDraw will be here, ready to plot its output.
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11.11 Filling shapes and text

The AxiDraw follows the actual vector paths in your documents, and thus nor-
mally ignores any “fill” inside shapes, since fills do not consist of vector paths.

A special utility is included with the AxiDraw software that can fill shapes with
vector paths - hatch marks - such that the shapes can be filled in with pen
strokes on your page. You can find it in the menu at Extensions > AxiDraw Util-
ities > Hatch fill.

[ BON ) Hatch fill

Hatch Fill Help

An extension to fill all (or selected) closed figures in your drawing with
paths consisting of back-and-forth hatch lines.

Hatch Spacing 3.000 -+
Spacing Units : px w
Hatch Angle (degrees) 450 — +

Crosshatch

Connect Nearby Ends

Range of end connections (default: 3) 3.0 =+

Inset Fill from Edges

Inset Distance, in selected units 1.000 - <4
Tolerance (default: 2.0) 20 — 4+

Live preview
Close Apply

Hatch Fill will fill any selected objects with a series of back and forth lines, with
adjustable spacing and angle. The hatch spacing is can be set in different units:
Screen pixels, inches, or mm. The default value of 3 px is often a good starting
value. A lower spacing will produce a more uniform fill, and a higher spacing will
produce a more traditional hatch fill for shading. You can use the “Live preview”
option to see the effects of different choices without actually applying them to
your shapes and text.
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The “Connect nearby ends” option, enabled by default, connects the ends of the
hatch lines to make long wiggling paths that plot very efficiently. An additional
option is provided for insetting the fill from the edges. This helps to avoid “color-
ing outside the lines” when using the hatch fill.

Here are some examples of how different settings can be used in Hatch Fill. Each
of the following are examples are shown actual size, with a 0.016 inch (0.4 mm)
stroke width, similar to that of a fine rollerball pen. The Tolerance parameter was
set to 1.0.

Objects, including The hatch fill
any applied hatches alone

{ | @ (1 No fill

(2): Spacing 3 px, Angle 0°.
Connect nearby ends: off
Inset: off

wma
()
o

‘ (3) Spacing 3 px, Angle 45°.
Connect nearby ends: off
Inset: on, distance 1.0

ANSSSRRNNN

VUL

if\'l % ’
/@ _

Ty (4) Spacing 3 px, Angle 45°.
Z Connect ends: On, Range 3.
Inset: on, distance 1.0

(5) Same as (4), but
with crosshatch: on

(6) Same as (4) but
with Spacing 1.0 px
(crosshatch is off)

Examples (4) and (6) above — with a single hatch at 45 degrees, inset from the
edges, and with the ends connected — usually give good results for most situa-
tions. The key parameter that you’ll need to adjust (based on the pen that you use
and so forth) is the Hatch Spacing.

RN

N

K

-
-
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11.12 Vectorizing images

The process of turning images (JPG, PNG, photoshop files, etc) into vector art-
work is generally outside the scope of the AxiDraw software. That said, how to do
so is a frequently asked question so we are including some notes on the subject.

The process of converting a photograph into a piece of pen-ready vector line art
can most accurately be described by the word “sketching” That is to say, it is not
so much a matter of file conversion as one of artistic interpretation. There are
genuinely a limitless number of ways to represent a photo with a set of strokes.
Artists that work with plotters often write their own programs to perform this
kind of conversion, and we will point out a few of these programs.

Inkscape includes a vectorizing tool, found in the menu at Path > Trace bitmap.
It works by tracing the outlines of darker regions. It does work, and is some-
times useful for very simple shapes, but it generally does not produce high quality
output that works well on plotters. You may end up with (for example) ghostly
effects, or tens of thousands of tiny little loops that represent stray pixels on the
input photo.

While this is nowhere near a comprehensive list, here are three examples of out-
put from different vector “sketching” programs. All three of these are free pro-
grams that are written and run in the Processing development environment.

This portrait was generated from an image with SquiggleDraw, available at:
https:/github.com/gwygonik/SquiggleDraw
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The portrait above on the left is a stipple drawing, made with thousands of tiny
circles of different sizes, as generated by StippleGen:
http://wiki.evilmadscientist.com/stipplegen

The portrait above on the right consists of a single wandering line. Plots like this
can potentially print quickly because there is no pen up/pen down movement.
This one was generated with an experimental program called ScribbleDraw, avail-
able upon request: https:/shop.evilmadscientist.com/contact

A third-party program that can render photographs into sketch paths is called
Drawing Bot V3, available from:
https:/github.com/SonarSonic/DrawingBotV3
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12. Maintenance and troubleshooting

AxiDraw V3 family plotters should not require any regular maintenance under
normal conditions.

12.1 Troubleshooting plot area

If you should find that the AxiDraw does not appear to have access to the full
plotting area of the machine, double check that you have selected the correct
model of AxiDraw in §9.11 The Config tab, on page 63.

12.2 No lubrication required

The X carriage contains wheels that allow the X shafts and Y parts to slide. The
wheels contain shielded and/or sealed ball bearing mechanisms that are perma-
nently filled with grease. The pen-lift (Z) stage uses grease-free Teflon-filled plain
bearings. NEVER apply oil or grease to any of the sliding mechanisms.

12.3 Cleaning

Clean the AxiDraw only with a soft, clean cloth. The non-electronic metal parts
may be cleaned with a cloth moistened with soap and water if needed. Avoid
other cleaners and solvents. Do not wet the motors, cables, or controller board.

12.4 Storage

It is recommended to store the AxiDraw with the carriage either in the Home po-
sition or (especially if it needs to be put away in a box) in the far opposite corner,
fully extended in X'and Y, such that the cable guides are fully extended and have
the lowest profile. Unplugging the AxiDraw’s plug-in power supply when not in
use for long periods of time will save power and prolong the life of the machine.

12.5 Belt tension

The AxiDraw uses a single timing belt, looped in an “X” shape around the two
motors and the Y carriage. This belt may gradually stretch a small amount, and
can be re-tensioned where it is anchored, if necessary. The necessary hex wrench
(2.5 mm) is included with the AxiDraw. Do not retension the belt unless it is ac-
tually necessary to do so.

12.6 The wrenches

Several hex wrenches and two thin-profile crescent wrenches are included with
the AxiDraw. The 2 mm ball-end wrench is used for switching the pen between
the vertical and angled orientations. The others are provided in case more sig-
nificant adjustments are required; they are not needed in most circumstances.
However, if something should come loose, it is nice to have the right tools on
hand. Contact technical support for guidance if needed.
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12.7 Wiring

If your motor wires should become disconnected at some point, the correct wire
order is as follows: Left motor: “Motor 2” locations, yellow, red, green, gray (from
top to bottom). Right motor: Motor 1 (same order). Servo cable: B1 (lowest three
pins on left hand side), with black wire towards the edge of the board. Referalso
to the illustrations in section “2.3 Unboxing AxiDraw” on page 14.

12.8 The pen-lift servo motor

The only expendable component of the AxiDraw is the pen-lift servo motor. They
do wear out over time but are inexpensive and straightforward to replace. For
applications where you cannot afford any down time, we recommend that you
keep a spare on hand. Spares are available at https:/emsl.us/903 and through
select resellers.

If you are setting up an AxiDraw for the first time and the pen-lift motor does
not appear to be operating, double-check that you have connected the cable
correctly, following along with §2.3 Unboxing AxiDraw, on page 14.

12.9 Loss of position

The most significant thing that can go wrong under normal operation is a loss
of position control while the carriage is moving. This is typically manifested as a
loud grinding or screeching noise. It can happen when moving at too high of a
speed, or when the carriage hits an unexpected obstacle- for example if it was
not moved to the Home Corner before plotting or if it was bumped while moving.

If this should happen, press the pause button as soon as possible to cancel the
plot. Remove power to the machine if necessary. Use Disable XY Motors or
Raise pen, turn off motors in the setup tab to de-energize the motors, and then
manually return the carriage to the Home Corner before trying to plot again. As
a sanity check, the carriage should return exactly to the Home Corner when a
plot is finished.

12.10 Wheel adjustments

The Xand Y carriages roll on wheels that are tensioned against them. It is possible
for these wheels to come slightly loose and need adjustment. If the AxiDraw’s
arm seems loose or floppy, please contact technical support and we can walk you
through the process.

12.11 Service, repair, and parts support

The AxiDraw is designed to be serviceable, and we are here to help. Nothing
should require regular replacement. However, most parts of the machine can be
unscrewed and replaced if necessary. Please contact technical support directly if
you need assistance with troubleshooting or repairing a mechanical issue.
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AxiDraw Tips and Tricks

It is often possible to get better print quality on top of a small stack of paper
(say, 5-10 sheets) which gives a little cushion to your writing.

High quality paper - especially paper designed for use with pens - tends to
give dramatically better results with pens than does cheap copy/laser paper.
Bristol paper with a smooth finish is a great example of a paper designed to
work well with pens.

The flatter that your paper is held, the better your print quality will be. Paper
that is warped or “bubbled” will flex as the pen writes, leading to distortion.
When the bubbles or warping are tall enough, it can also lead to stray marks
on your page during pen-up movements.

Reducing the amount of vertical pen travel that is needed will make your
plots faster, and also improve print quality, since the pen-lift servo motor
does introduce vibration.

If none of the motors move but (1) everything looks correct, and (2) your
computer doesn’t report any errors, triple check that the 9 V power supply is
plugged into a working outlet.

When making multiple-color plots, you can get better registration when
switching pens by making sure that each penis set to the same height above
the paper. A good way to do this is to rest the tip of the pen on a spacer when
tightening the pen in place. Use a small, flat piece of wood, plastic, or metal.
It is possible to completely detach the AxiDraw’s pen holder, and affix other
types of tools to the front of the Y carriage. Tapped M4 holes are provided
for mounting other types of tool heads there. We also sell a “rigid end effec-
tor” accessory, for specialized use cases: https:/emsl.us/899

Certain types of pens can “dry up” if left in the pen-up position for a minute
or two. This can lead to an awkward situation where ink does not start flowing
until after the machine has already been drawing for a bit. When working with
pens like this, it may be helpful to “bleed” out the tip with a bit of scratch
paper before printing.

Styles applied to paths (width, color, etc) are normally ignored by the Axi-
Draw software. If you have a dashed line and want it to plot with the dashes
visible, you can use Extensions > Modify Path > Convert to Dashes to con-
vert the dashes into separate path segments.

. One of the simplest things that you can do to improve the quality of your

output is to use a medium or broad-nibbed fountain pen. (Lamy Safari is an
excellent starter choice.)

A single rubber band can be looped loosely around the pen holder as shown,
to add a small amount of additional pressure for use with ball-point pens, or
for operating the AxiDraw in other orientations (where gravity is not readily
available to pull the pen to the surface). Do not add a rubber band unless it is
actually needed; the extra load will shorten the life of the pen-lift servo mo-
tor. Example rubber bands are included with the AxiDraw, but will degrade
over time.
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13.

14.

15.

16.

Inkscape has a keyboard shortcut, Alt-Q (Option-Q on Macs), which will ex-
ecute the last Inkscape extension once again. This is frequently useful when
repeating a command, such as making one additional copy of a plot, without
having to open the AxiDraw Control panel again.

You can also add your own keyboard shortcuts within Inkscape - for example,
maybe you want a shortcut for running the Disable XY Motors extension,
or to open the AxiDraw Control panel. To begin, open up Edit>Preferences
(Windows, Linux) or Inkscape>Preferences (Mac), and select Interface>Key-
board Shortcuts from the left-hand column.

When saving graphics in SVG format from CorelDRAW, a helpful tip is to
select the “Presentation attributes” option in the SVG export options. This
typically helps to make the formatting work better in Inkscape.

The order in which objects on your page will plot is generally determined by
the order in which they were initially drawn. “Lower” objects on the same
layer will print before “higher” objects on the same layer. You can use the
Object > Raise and Object > Lower commands to re-order objects. For more
about plot order, see §9.10 Plot order and optimization, on page 58.

A range of AxiDraw accessories are available, including larger-size pen hold-
ers, extra easel boards, magnetic easels, mounting hardware and more. For
details, please see https://emsl.us/902
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Online Resources

Extended online documentation
& resources for AxiDraw:

axidraw.com/docs

W Evil Mad
/M Scientist

Blog:
Store:
Docs:

Chat:

Humans:

www.evilmadscientist.com

shop.evilmadscientist.com

wiki.evilmadscientist.com

axidraw.com/chat

shop.evilmadscientist.com/contact
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